I am unable to remove tags from topics or messages on my site (no repro on try)


(Tobias Eigen) #1

I’m not sure what’s going on but recently I’ve been having trouble removing tags from topics. or messages. In the screenshot below, I want to change it from status-resolved to status-duplicate, but am unable to remove the status-resolved tag. There is no option available to X remove it as usual.


(Jeff Atwood) #2

I believe @techapj was troubleshooting something like this recently and it had to do with weird tag settings.


(Tobias Eigen) #3

I just updated to latest and am still having this same problem. I am now not ever able to remove tags from topics or messages.


(Daniela) #4

No repro on Try, I’m able to add/remove/create tags.

To know if it is a bug in the core or not you should try at least the safe-mode and in case try to disable the unofficial plugins


(Arpit Jalan) #5

@tobiaseigen Make sure to test this on a fresh topic on category which does not have any tag restrictions and set “Minimum number of tags required in a topic” for that category to 0.


(Tobias Eigen) #6

this is still happening on my site, even with safe mode and everything disabled. I’ll investigate further.


(Tobias Eigen) #7

One more note - I am not able to remove tags from topics or messages on my site at all. Just updated the title to reflect this, and that it has no repro on try or here on meta.

I watched more closely just now, and noticed that the first time I click into the box to edit tags, I do see the existing tags with X next to them but only for a fraction of a second. It is then replaced with the pulldown to add tags and is not accessible. The next times I click to edit tags I do not see the existing tags with X at all, unless I refresh the browser.

There is nothing specific to these actions in the log that I can see. I also don’t see anything in the javascript console.


(Sam Saffron) #8

Long shot, can you try a different browser (chrome / firefox / edge) I doubt this is the case but it is worth the long shot.


(Jeff Atwood) #9

Do you have any third-party plugins installed?


(Tobias Eigen) #10

Thanks Sam and Jeff - I tried firefox, same problem persists.

I do have some third-party plugins installed, which I can now easily identify thanks to the green check next to official plugins. The third-party plugins are: discourse-events, discourse-plugin-checklist, discourse-send-private-message, watch category (custom), discourse-whos-online, retort.

But shouldn’t safe mode deal with this? When in safe mode with theme and all plugins disabled, it still doesn’t work.

I also tried commenting out the plugins in the container file and rebuilding, and that also did not fix it.


(Tobias Eigen) #11

Amazingly, I was able to figure this out for myself. The functionality must have changed because it seemed much easier previously. Basically, to remove tags I have to start typing in letters in the tag search box. Then the tags with X to remove them will appear along with some results for new tags I might add. See screenshots.


(Ben Leong) #12

@tobiaseigen Thanks for posting that - we’ve been having exactly the same problem, where editing a post that contains tags will no longer give an option to delete those tags.

The workaround (edit post, search for tags by name, and then delete them) does the job. This is definitely a change from how it used to work, and it’s very unintuitive.