I cannot check docker name (● ˃̶͈̀ロ˂̶͈́)੭ꠥ⁾⁾


(ひさし) #1

I installed discourse on my server following below link.
INSTALL-cloud.md

Then, I tried to set up https: to my web site following below link.
Setting up Let’s Encrypt

And when I tried below, it does not work.

./launcher rebuild <container name>

Actually I do not know my container name, so I tried to $container ps, but there is not any container.

$  docker ps
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES

Does anyone have good idea?:slight_smile:


(Andrew Waugh) #2

Usually the container name is “app”. It comes from the .yml file which is created by discourse-setup.

Look in /var/discourse/containers. if it’s a standard install then there will be a file named app.yml in that folder - that is the name of your container, without the .yml extension.


(ひさし) #3

thanks @JagWaugh

I tried $ ./launcher rebuild app ,but I have a error like below.

Do you have any idea??

$ ./launcher rebuild app
 stat: /var/lib/docker: stat: No such file or directory
 ./launcher: line 204: /1024**3 < 5: syntax error: operand expected (error token is "/1024**3 < 5")
 Ensuring launcher is up to date
 error: cannot open .git/FETCH_HEAD: Permission denied
 Launcher is up-to-date
 cd /pups && git pull && /pups/bin/pups --stdin
 /usr/local/bin/docker: Failed to create the container ID file: open cids/app_bootstrap.cid: permission denied.
 See '/usr/local/bin/docker run --help'.
 cat: cids/app_bootstrap.cid: No such file or directory
 "docker rm" requires at least 1 argument.
 See 'docker rm --help'.

 Usage:  docker rm [OPTIONS] CONTAINER [CONTAINER...] [flags]

 Remove one or more containers
 rm: cids/app_bootstrap.cid: No such file or directory
 ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

(Andrew Waugh) #4

Did you run ./launcher as root?

if not, try:

sudo ./launcher rebuild app

If you did run it as root, then try

cd /var/discourse
git pull

The above shouldn’t give any error messages.


(ひさし) #5

well… I cannot still rebuild app…

[Mac:discourse zyouchi$ sudo ./launcher rebuild app

stat: /var/lib/docker: stat: No such file or directory
./launcher: line 204: /1024**3 < 5: syntax error: operand expected (error token is "/1024**3 < 5")
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
cd /pups && git pull && /pups/bin/pups --stdin
/usr/local/bin/docker: Error response from daemon: Mounts denied: 
The paths /var/discourse/shared/standalone/log/var-log and /var/discourse/shared/standalone
are not shared from OS X and are not known to Docker.
You can configure shared paths from Docker -> Preferences... -> File Sharing.
See https://docs.docker.com/docker-for-mac/osxfs/#namespaces for more info.

(Andrew Waugh) #6

Ah, I see you’re running docker on a mac. It looks like there’s something wrong with your docker install. I’m not up on mac installs, but…

What does

sudo docker info

say?


(ひさし) #7

Yes, I’m using mac,

$ sudo docker info

Password:
Containers: 0
 Running: 0
 Paused: 0
 Stopped: 0
Images: 1
Server Version: 18.03.1-ce
Storage Driver: overlay2
 Backing Filesystem: extfs
 Supports d_type: true
 Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
 Volume: local
 Network: bridge host ipvlan macvlan null overlay
 Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 773c489c9c1b21a6d78b5c538cd395416ec50f88
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
 seccomp
Profile: default
Kernel Version: 4.9.87-linuxkit-aufs
Operating System: Docker for Mac
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.952GiB
Name: linuxkit-025000000001
ID: T52B:MZXF:B3RI:QCTH:2LZG:H665:C5PW:G6GI:BABO:T4LJ:OXZJ:ORBD
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
 File Descriptors: 24
 Goroutines: 54
 System Time: 2018-07-01T06:38:28.3688819Z
 EventsListeners: 2
HTTP Proxy: docker.for.mac.http.internal:3128
HTTPS Proxy: docker.for.mac.http.internal:3129
Registry: https://index.docker.io/v1/
Labels:
Experimental: true
Insecure Registries:
 127.0.0.0/8
Live Restore Enabled: false

(Andrew Waugh) #8

We’re outside my experience domain here.

I would try restarting the docker service (or the host itself), if that doesn’t help then I’d be looking at your shared paths configuration as suggested below.

As I understand it your install isn’t finding some files or folders which are needed to run. If docker on mac is similar to docker on Synology then you’re missing a symbolic link from the host fs to a share/folder in userspace.


(ひさし) #9

I’m manually install following this link.Docker package for your OS