I cant instal plugin (Advertising Plugin)


(Cheng Trang) #1

I not found Adv Plugin in the Plugin tab .
I installed step by step of guide :GitHub - discourse/discourse-adplugin: Official Discourse Advertising Plugin. Install & Start Serving Ads on Your Discourse Forum

This is video i doing.


Please help me.


(Vinoth Kannan) #2

In your rebuild attempt it is intercepted since not enough disk space. Then cleanup task asked you to clean the disk by deleting unwanted containers. By pressing ‘y’ you done it. But rebuilding process to executed I guess. So please try rebuilding again using the command ./launcher rebuild app


(Cheng Trang) #3

Yes.I run try again but like first time…I using VPS RAM 1G+ SWAP 2048k…


(Vinoth Kannan) #4

It tells you have less than 5 GB disk space in /var/lib/docker folder. Check the disk space available (not RAM and SWAP)


(Cheng Trang) #5

This is disk space:


(Joshua Rosenfeld) #6

Right, and that shows exactly what @vinothkannans said, less than 5 GB of free (Avail) space.


(Cheng Trang) #7

Yes, i know…
How i can increase disk space (/dev/vda1)? It is 4G Avail


(Joshua Rosenfeld) #8

To increase the space you’d likely need to upgrade your VPS with your provider. Alternately, take a look at what is using the 20 GB and see if some of it can be cleaned up (to decrease your used space).


(Jay Pfaffman) #9

You might try ./launcher cleanup.


(Cheng Trang) #10

Thank everbody…Now, i upgrade VPS and I run but error:

 FAILED
    --------------------
    NoMethodError: undefined method `each' for "git clone https://github.com/discourse/discourse-adplugin.git":String
    Location of failure: /pups/lib/pups/config.rb:100:in `block in run_commands'
    exec failed with the params {"cd"=>"$home/plugins", "cmd"=>["mkdir -p plugins", "git clone https://github.com/discourse/docker_manager.git"]}
    0c954aa9b150c906c542d06f015f211cf5073bf59779f0143ce0f8a56457127c
    ** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one