# I can't start a Discourse

**URL:** https://meta.discourse.org/t/i-cant-start-a-discourse/287894
**Category:** Self-hosting
**Created:** [December 7, 2023, 9:31pm UTC](https://meta.discourse.org/t/i-cant-start-a-discourse/287894 "2023-12-07T21:31:54Z")
**Posts on this page:** 1
**Showing post:** 36

<div class="post-metadata">

### Author: ![Jagster](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagster/32/192154_2.png) [@Jagster](https://meta.discourse.org/u/Jagster)
#### Post date: [December 9, 2023, 5:15pm UTC](https://meta.discourse.org/t/i-cant-start-a-discourse/287894/36 "2023-12-09T17:15:10Z")

</div>

Have you red this:

> [@After upgrade, docker cannot communicate with the outside world](https://meta.discourse.org/t/after-upgrade-docker-cannot-communicate-with-the-outside-world/171902):
>
> I woke up this morning to reports that my discourse server was “down”. I was able to ssh into the server without a problem, noticed some security updates needed to be applied, applied them with apt full-upgrade, and restarted the server with reboot. Took a little while to come back up but when it did I checked that the discourse docker container was running. Oddly, no problem. Tried stopping and restarting with ./launcher app stop and ./launcher app start. Didn’t help. Tried doing a ./lau…

Or this:

> [@Install fails with port 80,443 on GCP](https://meta.discourse.org/t/install-fails-with-port-80-443-on-gcp/155313):
>
> Hi, I created a VM with GCP compute engine. My domain name is [solarnauts.net](http://solarnauts.net) (from Namecheap) I have created a DNS A-record, for the host I have put the subdomain [discourse.solarnauts.net](http://discourse.solarnauts.net) and for the value, the external IP of my VM. When I run ./discourse-setup, I get the port 80 and 443 warnings (see down below). Despite add a firewall rule to my VM opening these 2 ports, i still get this error. What do you advise? Thanks Checking your domain name . . .WARNING: Port 443 of computer does n…

Or this:

> [@Failed to Bootstrap Ping is working to github](https://meta.discourse.org/t/failed-to-bootstrap-ping-is-working-to-github/23869):
>
> root@daysrilanka:~# mkdir /var/discourse root@daysrilanka:~# git clone https://github.com/discourse/discourse\_docker.git /var/discourse Cloning into '/var/discourse'... remote: Counting objects: 1353, done. remote: Compressing objects: 100% (6/6), done. remote: Total 1353 (delta 2), reused 0 (delta 0) Receiving objects: 100% (1353/1353), 301.74 KiB | 115.00 KiB/s, done. Resolving deltas: 100% (791/791), done. Checking connectivity... done. root@daysrilanka:~# cd /var/discourse root@daysrilanka:/…

There are several topics that are close to same issues you have.

Sorry, but I have sub-zero knowledge of docker 🥴

---

_[View the full topic](https://meta.discourse.org/t/i-cant-start-a-discourse/287894)._
