# Tengo un error al intentar reconstruir la aplicación

**URL:** https://meta.discourse.org/t/i-have-error-when-try-to-rebuild-app/202100
**Category:** Self-hosting
**Created:** [30 Agosto, 2021 10:51 UTC](https://meta.discourse.org/t/i-have-error-when-try-to-rebuild-app/202100 "2021-08-30T10:51:12Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [30 Agosto, 2021 10:51 UTC](https://meta.discourse.org/t/i-have-error-when-try-to-rebuild-app/202100/1 "2021-08-30T10:51:12Z")

</div>

Tengo este error al intentar reconstruir la aplicación. Nunca lo había visto antes.  
Intenté reiniciar, pero el error sigue presente.

```plaintext
$: ./launcher rebuild app

HEAD is now at d1db030 cut a new version
I, [2021-08-30T10:45:51.096586 #1] INFO -- : Loading --stdin
I, [2021-08-30T10:45:51.102601 #1] INFO -- : > locale-gen $LANG && update-locale
I, [2021-08-30T10:45:51.173412 #1] INFO -- : Generating locales (this might take a while)...
Generation complete.

I, [2021-08-30T10:45:51.173963 #1] INFO -- : > mkdir -p /shared/postgres_run
I, [2021-08-30T10:45:51.176980 #1] INFO -- : 
I, [2021-08-30T10:45:51.177439 #1] INFO -- : > chown postgres:postgres /shared/postgres_run
I, [2021-08-30T10:45:51.180188 #1] INFO -- : 
I, [2021-08-30T10:45:51.180610 #1] INFO -- : > chmod 775 /shared/postgres_run
I, [2021-08-30T10:45:51.182946 #1] INFO -- : 
I, [2021-08-30T10:45:51.183287 #1] INFO -- : > rm -fr /var/run/postgresql
I, [2021-08-30T10:45:51.186650 #1] INFO -- : 
I, [2021-08-30T10:45:51.187032 #1] INFO -- : > ln -s /shared/postgres_run /var/run/postgresql
I, [2021-08-30T10:45:51.190969 #1] INFO -- : 
I, [2021-08-30T10:45:51.191391 #1] INFO -- : > socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1
I, [2021-08-30T10:45:51.218392 #1] INFO -- : postgres already running stop container

FAILED
--------------------
Pups::ExecError: socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1 failed with return #<Process::Status: pid 35 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"
e9aa4286bc2f13a785e2be5d148485f1fca4a27de84256071f4ad53d029883a9
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

```
