# I have error when upgrade latest discourse

**URL:** https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105
**Category:** Support
**Created:** [February 13, 2025, 4:21pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105 "2025-02-13T16:21:54Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [February 13, 2025, 4:21pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/1 "2025-02-13T16:21:54Z")

</div>

I have error when upgrade latest discourse:

```plaintext
Checking for extension updates notice

Your installation contains extensions that should be updated
with the ALTER EXTENSION command. The file
    update_extensions.sql
when executed by psql by the database superuser will update
these extensions.

Upgrade Complete
----------------
Optimizer statistics are not transferred by pg_upgrade.
Once you start the new server, consider running:
    /usr/lib/postgresql/15/bin/vacuumdb --all --analyze-in-stages

Running this script will delete the old cluster's data files:
    ./delete_old_cluster.sh
-------------------------------------------------------------------------------------
UPGRADE OF POSTGRES COMPLETE

Old 13 database is stored at /shared/postgres_data_old

To complete the upgrade, rebuild again using:

./launcher rebuild app

```

---

<div class="post-metadata">

### Author: ![merefield](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/merefield/32/176214_2.png) [@merefield](https://meta.discourse.org/u/merefield)
#### Post date: [February 13, 2025, 4:25pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/2 "2025-02-13T16:25:32Z")

</div>

> [@cmdntd](#):
>
> ```plaintext
> To complete the upgrade, rebuild again using:
> 
> ./launcher rebuild app
> 
> ```

I see no error, I just see next steps

---

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [February 13, 2025, 4:32pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/3 "2025-02-13T16:32:00Z")

</div>

I contitue to run, and it shows errors:

```plaintext
2025-02-13 16:30:53.012 UTC [43] LOG: database system is shut down
110:M 13 Feb 2025 16:30:53.028 * DB saved on disk
110:M 13 Feb 2025 16:30:53.029 # Redis is now ready to exit, bye bye...

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'SKIP_EMBER_CLI_COMPILE=1 bundle exec rake themes:update assets:precompile' failed with return #<Process::Status: pid 1157 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "tag"=>"precompile", "hook"=>"assets_precompile", "cmd"=>["su discourse -c 'SKIP_EMBER_CLI_COMPILE=1 bundle exec rake themes:update assets:precompile'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

```

---

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [February 13, 2025, 4:51pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/4 "2025-02-13T16:51:03Z")

</div>

I run `doctor` again, and it seems ok.  
But I’m not sure about this issue.

---

<div class="post-metadata">

### Author: ![Canapin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/canapin/32/119591_2.png) [@Canapin](https://meta.discourse.org/u/Canapin)
#### Post date: [February 13, 2025, 5:32pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/5 "2025-02-13T17:32:27Z")

</div>

> [@cmdntd](#):
>
> `please scroll up and look for earlier error messages`

Can you scroll up and look for earlier error messages, and paste them here?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [February 14, 2025, 1:17am UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/6 "2025-02-14T01:17:33Z")

</div>

My guess is that you’re out of me m memory? Have you tried to run the rebuild again?

How much ram and swap do you have (free -h)

---

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [February 14, 2025, 5:30am UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/7 "2025-02-14T05:30:24Z")

</div>

It runs ok, so I can not see them any more.

---

<div class="post-metadata">

### Author: ![cmdntd](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cmdntd/32/192008_2.png) [@cmdntd](https://meta.discourse.org/u/cmdntd)
#### Post date: [February 14, 2025, 5:30am UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/8 "2025-02-14T05:30:55Z")

</div>

Thanks. I will pay attention to ram at next version updates.

---

<div class="post-metadata">

### Author: ![Jonathan5](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jonathan5/32/197134_2.png) [@Jonathan5](https://meta.discourse.org/u/Jonathan5)
#### Post date: [March 10, 2025, 1:22pm UTC](https://meta.discourse.org/t/i-have-error-when-upgrade-latest-discourse/352105/9 "2025-03-10T13:22:57Z")

</div>

> [@cmdntd](#):
>
> ```plaintext
> Your installation contains extensions that should be updated
> with the ALTER EXTENSION command. The file
> update_extensions.sql
> when executed by psql by the database superuser will update
> these extensions.
> 
> ```

I saw this too (though my upgrade went all right otherwise). I guess it’s nothing to worry about – is that right?
