IE10 user is getting "your browser is too old"?


(Clever Moniker) #1

I have a forum with discoursehosting.com.

In setting up my mod team, I have a friend who uses IE10, but isn’t computer savy at all. :frowning: So doesn’t want to mess with his current setup as he gets lost if he does.

SO…

I know IE10 is supported, yet he says he is getting “Unfortunately, your browser is too old to work on this Discourse forum.”

What could possibly be causing this??

Please help.


(Jeff Atwood) #2

I don’t think your friend is actually using IE10?

Can you get him to do Help / About and show a screenshot of the version?

Alternately have him visit here

http://whatbrowser.org/

IE9 is barely supported, it is our literal minimum browser though. The experience will be… not good. IE10 is fully supported as is IE11, no limitations at all, they work perfectly.


(Clever Moniker) #3

Thanks for the reply @codinghorror.

He doesn’t know how to do a screenshot unfortunatelty. As I have tried to get him to do this in the past. :frowning:

I will get him to look it up in whatbrowser.org, and see.

He is from the UK, so he will be able to let me know tomorrow.

Thanks again for the quick response.


(Clever Moniker) #4

He just got back to me @codinghorror.

He said it says MSIE 10.

:S

What could it be then!? :


(Jens Maier) #5

Tell him to find a knowledgeable person and to get them to physically sit down in front of his computer to have a look. Trying to fix this via the Internet will only end in headaches and tears.

And possibly complaints like “I thought you knew this stuff”.

If I had to hazard a guess, he will have at least three different virus scanners and/or “Internet Security Tools” installed and has followed all kind of ill-conceived tips like disabling JavaScript or raising IE’s security level. Memes like this are, unfortunately, only slightly exaggerated…


(Jeff Atwood) #6

I sadly must agree with @elberet here – something is direly wrong on his machine.

I used IE10 to browse many Discourse sites for a year, until Windows 8.1 was released (which includes IE11).


(Clever Moniker) #7

Arrrg, must need an update then.

He did say he was running Norton. Maybe a conflict I suspect?

Thanks for the help guys.


(cpradio) #8

Maybe it is running in compatibility mode for your discourse site?


(Clever Moniker) #9

@cpradio Will check in the morning!! :smile:

All my research so far seems to point to this as a contributing factor.


(Jens Maier) #10

I added discourse.org to my IE’s compatibility mode list and got the ‘Please upgrade your browser’ message myself – nice catch, I didn’t think of that and will make a mental memo for the next time someone bugs me with an ID-10-T problem. :wink:


(Clever Moniker) #11

Even still @elberet, that meme is priceless. :wink:


(Clever Moniker) #12

Verified, this was the issue!!! It is fixed now.

Thanks @cpradio.

So, in order to view in IE10, compatibility mode must be turned off.

For those who have this issue, this is what we did to fix it:

  1. Go to the forum
  2. Press the Alt key, and click on the Tools menu.
  3. Click Compatibility View Settings
  4. If you see the forum listed, click on it and remove.

Cheers,
Clever Moniker


(Rikki Tooley) #13

Could we add this to the messaging? I’ve seen it done on other sites (will edit on screened when I’m at my computer)


(Clever Moniker) #14

This is true @haiku, is it possible to have this added to the warning @codinghorror?


(Jeff Atwood) #15

Since IE compatibility mode has to be manually turned on (it is not on by default – no idea why it was on that user’s machine) I am not sure this is worth the additional bytes served up to 99.99% of users who won’t have this rare condition.

Having the topic here will suffice for now, I think, until we have at least 1 other report of this in the wild.


(cpradio) #16

Not wanting to push unnecessary changes related to an older browser, but can’t we by design force a header to prevent compatibility mode?


(Moshe Katz) #17

The meta tag to do this would be:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

(note that this must be the first meta tag, or you may get the error, “X-UA-Compatible META tag ignored because document mode is already finalized.”)

or the equivalent nginx config would be:

add_header X-UA-Compatible IE=edge

Like @codinghorror, I see no reason to add this to the default template or configuration, but there’s nothing stopping you from adding it to your own site,


(Sam Saffron) #18

We can ship the header that disables this in nginx. Its just one extra header.


(Sam Saffron) #19

Sure, the file that needs changing is discourse/nginx.sample.conf at master · discourse/discourse · GitHub

You can test it works by mucking around in a docker instance … just ./launcher ssh in… the file is in /etc/nginx …

Care to try a PR.

The key is only to add the header for rails stuff.

Alternatively we could have our rails middleware add the header.


(Moshe Katz) #20

I put in a PR.

https://github.com/discourse/discourse/pull/2325

@sam, I didn’t put it for only the rails stuff as you suggested, because I’m not sure if it really matters. If you really want it only for the Rails stuff, I’ll fix and resubmit.