# I'm running into this error

**URL:** https://meta.discourse.org/t/im-running-into-this-error/265664
**Category:** Self-hosting
**Created:** [May 20, 2023, 6:54pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664 "2023-05-20T18:54:17Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Wleksion](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/wleksion/32/306986_2.png) [@Wleksion](https://meta.discourse.org/u/Wleksion)
#### Post date: [May 20, 2023, 6:54pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/1 "2023-05-20T18:54:17Z")

</div>

```plaintext
2023-05-20 18:50:24.008 UTC [57] LOG: received fast shutdown request
2023-05-20 18:50:24.016 UTC [57] LOG: aborting any active transactions
2023-05-20 18:50:24.026 UTC [57] LOG: background worker "logical replication launcher" (PID 66) exited with exit code 1
2023-05-20 18:50:24.027 UTC [61] LOG: shutting down
118:M 20 May 2023 18:50:24.060 # User requested shutdown...
118:M 20 May 2023 18:50:24.060 * Saving the final RDB snapshot before exiting.
118:M 20 May 2023 18:50:24.066 * DB saved on disk
118:M 20 May 2023 18:50:24.067 # Redis is now ready to exit, bye bye...
2023-05-20 18:50:24.068 UTC [57] LOG: database system is shut down

```

The system gives these errors and does not work

---

<div class="post-metadata">

### Author: ![hello-smile6](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/hello-smile6/32/304628_2.png) [@hello-smile6](https://meta.discourse.org/u/hello-smile6)
#### Post date: [May 20, 2023, 7:02pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/2 "2023-05-20T19:02:20Z")

</div>

Could you provide more details? What’s happening before that?

---

<div class="post-metadata">

### Author: ![Wleksion](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/wleksion/32/306986_2.png) [@Wleksion](https://meta.discourse.org/u/Wleksion)
#### Post date: [May 20, 2023, 7:04pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/3 "2023-05-20T19:04:29Z")

</div>

```plaintext
Turn off this advice by setting config variable advice.detachedHead to false

I, [2023-05-20T18:50:20.309089 #1] INFO -- : 
I, [2023-05-20T18:50:20.309217 #1] INFO -- : > touch /var/spool/cron/crontabs/root
I, [2023-05-20T18:50:20.316069 #1] INFO -- : 
I, [2023-05-20T18:50:20.316703 #1] INFO -- : > install -d -m 0755 -g root -o root $LETSENCRYPT_DIR
I, [2023-05-20T18:50:20.325079 #1] INFO -- : 
I, [2023-05-20T18:50:20.325219 #1] INFO -- : > cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --install --log "${LETSENCRYPT_DIR}/acme.sh.log"
I, [2023-05-20T18:50:21.265616 #1] INFO -- : [Sat 20 May 2023 06:50:20 PM UTC] Installing to /shared/letsencrypt
[Sat 20 May 2023 06:50:20 PM UTC] Installed to /shared/letsencrypt/acme.sh
[Sat 20 May 2023 06:50:20 PM UTC] Installing alias to '/root/.profile'
[Sat 20 May 2023 06:50:20 PM UTC] OK, Close and reopen your terminal to start using acme.sh
[Sat 20 May 2023 06:50:20 PM UTC] Installing cron job
[Sat 20 May 2023 06:50:20 PM UTC] Good, bash is found, so change the shebang to use bash as preferred.
[Sat 20 May 2023 06:50:21 PM UTC] OK

I, [2023-05-20T18:50:21.265799 #1] INFO -- : > cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --upgrade --auto-upgrade
I, [2023-05-20T18:50:23.925000 #1] INFO -- : [Sat 20 May 2023 06:50:21 PM UTC] Installing from online archive.
[Sat 20 May 2023 06:50:21 PM UTC] Downloading https://github.com/acmesh-official/acme.sh/archive/master.tar.gz
[Sat 20 May 2023 06:50:22 PM UTC] Extracting master.tar.gz
[Sat 20 May 2023 06:50:22 PM UTC] Installing to /shared/letsencrypt
[Sat 20 May 2023 06:50:22 PM UTC] Installed to /shared/letsencrypt/acme.sh
[Sat 20 May 2023 06:50:22 PM UTC] Good, bash is found, so change the shebang to use bash as preferred.
[Sat 20 May 2023 06:50:23 PM UTC] OK
[Sat 20 May 2023 06:50:23 PM UTC] Install success!
[Sat 20 May 2023 06:50:23 PM UTC] Upgrade success!

I, [2023-05-20T18:50:23.925858 #1] INFO -- : > cd /root/acme.sh && LE_WORKING_DIR="${LETSENCRYPT_DIR}" ./acme.sh --set-default-ca --server letsencrypt
I, [2023-05-20T18:50:23.976164 #1] INFO -- : [Sat 20 May 2023 06:50:23 PM UTC] Changed default CA to: https://acme-v02.api.letsencrypt.org/directory

I, [2023-05-20T18:50:23.980913 #1] INFO -- : File > /etc/nginx/letsencrypt.conf chmod: chown: 
I, [2023-05-20T18:50:23.988140 #1] INFO -- : File > /etc/runit/1.d/letsencrypt chmod: +x chown: 
I, [2023-05-20T18:50:23.989411 #1] INFO -- : Replacing (?-mix:ssl_certificate.+) with ssl_certificate /shared/ssl/$$ENV_DISCOURSE_HOSTNAME.cer;
ssl_certificate /shared/ssl/$$ENV_DISCOURSE_HOSTNAME_ecc.cer;
 in /etc/nginx/conf.d/discourse.conf
I, [2023-05-20T18:50:23.990713 #1] INFO -- : Replacing (?-mix:#?ACCOUNT_EMAIL=.+) with ACCOUNT_EMAIL=$$ENV_LETSENCRYPT_ACCOUNT_EMAIL
 in /shared/letsencrypt/account.conf
I, [2023-05-20T18:50:23.991830 #1] INFO -- : Replacing (?-mix:ssl_certificate_key.+) with ssl_certificate_key /shared/ssl/$$ENV_DISCOURSE_HOSTNAME.key;
ssl_certificate_key /shared/ssl/$$ENV_DISCOURSE_HOSTNAME_ecc.key;
 in /etc/nginx/conf.d/discourse.conf
I, [2023-05-20T18:50:23.992752 #1] INFO -- : Replacing (?-mix:add_header.+) with add_header Strict-Transport-Security 'max-age=63072000'; in /etc/nginx/conf.d/discourse.conf
I, [2023-05-20T18:50:23.993416 #1] INFO -- : Replacing location @discourse { with location @discourse {
add_header Strict-Transport-Security 'max-age=31536000'; # remember the certificate for a year and automatically connect to HTTPS for this domain in /etc/nginx/conf.d/discourse.conf
I, [2023-05-20T18:50:23.994599 #1] INFO -- : > echo "Beginning of custom commands"
I, [2023-05-20T18:50:23.998577 #1] INFO -- : Beginning of custom commands

I, [2023-05-20T18:50:23.999094 #1] INFO -- : > echo "End of custom commands"
I, [2023-05-20T18:50:24.002961 #1] INFO -- : End of custom commands

I, [2023-05-20T18:50:24.006766 #1] INFO -- : Terminating async processes
I, [2023-05-20T18:50:24.007874 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 57
I, [2023-05-20T18:50:24.008783 #1] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 118
118:signal-handler (1684608624) Received SIGTERM scheduling shutdown...
2023-05-20 18:50:24.008 UTC [57] LOG: received fast shutdown request
2023-05-20 18:50:24.016 UTC [57] LOG: aborting any active transactions
2023-05-20 18:50:24.026 UTC [57] LOG: background worker "logical replication launcher" (PID 66) exited with exit code 1
2023-05-20 18:50:24.027 UTC [61] LOG: shutting down
118:M 20 May 2023 18:50:24.060 # User requested shutdown...
118:M 20 May 2023 18:50:24.060 * Saving the final RDB snapshot before exiting.
118:M 20 May 2023 18:50:24.066 * DB saved on disk
118:M 20 May 2023 18:50:24.067 # Redis is now ready to exit, bye bye...
2023-05-20 18:50:24.068 UTC [57] LOG: database system is shut down
sha256:d0eaff2960589e6490608fa882bddaf493748f1b847d7006cae16765012af258
755217c749f30ea4e76a5d8b2493cf299cd2b598f6274255d5b88b045c3de430

`

```

---

<div class="post-metadata">

### Author: ![twofoursixeight](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/twofoursixeight/32/574822_2.png) [@twofoursixeight](https://meta.discourse.org/u/twofoursixeight)
#### Post date: [May 20, 2023, 7:29pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/4 "2023-05-20T19:29:07Z")

</div>

It appears that your database system is being shut down after executing some custom commands. I think this error means that there is an issue with your database. (edited)  
(or it could be perfectly fine?)  
Other sources: [LOG: database system is shut down. How to fix it - #2 by itsbhanusharma](https://meta.discourse.org/t/log-database-system-is-shut-down-how-to-fix-it/107894/2)

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [May 20, 2023, 8:35pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/5 "2023-05-20T20:35:28Z")

</div>

That’s the output of a successful rebuild. We need the full logs if it’s not working after that.

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [May 23, 2023, 7:58pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/6 "2023-05-23T19:58:31Z")

</div>

After checking @Wleksion server the problem was caused by a faulty DNS configuration and multiple rebuilds triggering the Let’s Encrypt Rate Limit.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [June 22, 2023, 7:59pm UTC](https://meta.discourse.org/t/im-running-into-this-error/265664/7 "2023-06-22T19:59:03Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
