Image popover/hover doesn't show except on .png's


(Jamie Lormand) #1

I apologize if this is a non issue or has been mentioned / dealt with already. I wasn’t able to find evidence that it has been so I thought I’d mention it.

I uploaded a number of images to the Staff->Assets post after first setting up my discourse install (the docker install). After a few days I noticed the image popover bar wasn’t working and at first thought it was site wide so I tried numerous things to get it working again with no success. Tonight however, I realized it’s working just fine for png’s but nothing else. I tested this by swapping a jpeg for a png and a few minutes later it was working again where the previous jpeg wasn’t.

If this is a bug, no worries, I’m sure it’ll get fleshed out eventually.

If, by chance, it’s a limitation of some sort or a purposely implemented feature would there be an alternate way to handle it? Maybe automatic conversion to png or an admin option to turn off the hover box entirely. I like it but if it’s limited to png’s it’s kinda weird to have. I feel like the end users will think the same as I did at first and see it as a broken feature.

Random side note: Thanks for Discourse. I really enjoy using it. It’s an awesome alternative to old school forums. You guys have done a top notch job with this.


(Jeff Atwood) #2

Thanks! Let’s see:

That is a large jpg I just uploaded.


(Jeff Atwood) #3

Here is a sample large jpeg I just uploaded.

Maybe your jpeg files happen to be too small in dimensions (height × width) to trigger lightboxing?


(Jamie Lormand) #4

For the images I uploaded to the Assets post that seems to be the issue. I didn’t even consider dimensions when trying to fix this :smile:

The image I swapped for a png is 1077x3188 and it showed the lightbox after it was a png but not before, so I’m not entirely sure dimensions are my only issue there.

Below is the image that didn’t work on my site in it’s jpeg form. Let’s see if it works here.

I don’t seem to be able to do it here but on mine I have the dimensions set to width=“539” height=“1594” so maybe that had something to do with it? Even with the custom dimensions it still didn’t work on mine till it was a png.


(Jamie Lormand) #5

So that same image is now working on my discourse install. Not sure what changed but it didn’t work for weeks and I just swapped it for the png last night but now it works for the jpeg as well. Maybe it was an error on the first upload or one of the recent updates, I’m running the absolute latest update from the docker manager.

Either way, my apologies for bugging you about what’s apparently a non issue. Thanks again for all the great work you guys are doing. I would offer to help if I had more time and knew anything about Ruby or Docker :smiley:


(Régis Hanol) #6