Imap - Settings


(Thomas Burmeister) #1

Hi! We are new in discourse and have hosted it on a cloud-server from 1&1 in Germany.

Everything works fine, except the eMail-settings. When I go to “administration” and then to “E-Mails” I see the following settings:

Versandmethode
address localhost
port 25
domain localhost.localdomain
user_name
authentication
enable_starttls_auto true

I think, it´s impossible, to send any email with these settings :slight_smile: And indeed, a testmail does not arrive! Is it right, that I have to fill out the fields above with the data of my eMail-provider? And if yes: How can I do this? There ist no button!

Best regards
Thomas


(Lutz Biermann) #2

You need to fill out the " DISCOURSE_SMTP_*" settings in “/var/discourse/containers/app.yml”.
After this a rebuild is needed:

cd /var/discourse
./launcher rebuild app

Please have a look at Set up Discourse in the cloud in under 30 minutes and read the Email part.

As a german user, you may also want to set this:

db_default_text_search_config: "pg_catalog.german"
DISCOURSE_DEFAULT_LOCALE: de

Otherwise, some texts are in English. It is important to set these settings before the first installation. Once the texts are in the database, it must be deleted in order to get the correct language.


(Jeff Atwood) #3

The ./discourse-setup script prompts for these values, so it sounds like the official install guide was not followed here?


(Thomas Burmeister) #4

that´s right! 1&1 installs the whole package without any influence from us


(Jeff Atwood) #5

Is this a docker-based install? We only support the Docker based install here.