# Impossible to run in Plesk Ubuntu -too many issues eg. Redis network connect

**URL:** https://meta.discourse.org/t/impossible-to-run-in-plesk-ubuntu-too-many-issues-eg-redis-network-connect/391360
**Category:** Self-hosting
**Tags:** unsupported-install
**Created:** [15 בדצמבר,‏ 2025,‏ 3:31pm UTC](https://meta.discourse.org/t/impossible-to-run-in-plesk-ubuntu-too-many-issues-eg-redis-network-connect/391360 "2025-12-15T15:31:35Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![Skie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/skie/32/502384_2.png) [@Skie](https://meta.discourse.org/u/Skie)
#### Post date: [15 בדצמבר,‏ 2025,‏ 3:31pm UTC](https://meta.discourse.org/t/impossible-to-run-in-plesk-ubuntu-too-many-issues-eg-redis-network-connect/391360/1 "2025-12-15T15:31:35Z")

</div>

Ionos XL VPS Ubuntu Plesk. With apps eg Wordpress. Also using Redis. So need to use same Redis install on same server for Discourse. Seems to be an issue.  
Docker Install.  
Can not build. Error Redis can not connect. Yes did every conceivable variation in app.yml & redis.config & nginx & apache. 1 week with Deepseek, Chatgpt, Gemini, Grok, nobody on earth can solve this.  
Domain & Hosting & DNS is setup in Plesk, Ionos account area for Firewall. Everything else done in Bash.  
Install procedure notes to myself : [Discourse install on Plesk Ubuntu with Docker](https://docs.google.com/document/d/16p3Erd81MyBQWg1KUPwnDF2bs4DRbzc2lmcUMfjkZdU/edit?usp=sharing)  
app.yml: [app.yml](https://drive.google.com/file/d/1A0YlLbL7LC2zGjxIhw-2rQO74Sf6vsQL/view?usp=sharing)  
redis.config: [redis.config](https://drive.google.com/file/d/1cgI6l6zTQRWXw7UxujUZhoOyvqlBaGE0/view?usp=sharing)  
Discourse location: root@determined-ptolemy:/var/www/vhosts/make.ooo/forum.make.ooo/discourse\_docker#  
Build error:  
\< 112:M 15 Dec 2025 15:23:12.908 \* DB saved on disk  
112:M 15 Dec 2025 15:23:12.908 # Redis is now ready to exit, bye bye…

## FAILED

Pups::ExecError: cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’ failed with return #\<Process::Status: pid 4484 exit 1\>  
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.3.0/lib/pups/exec\_command.rb:131:in `spawn’  
exec failed with the params {“cd”=\>“$home”, “tag”=\>“migrate”, “hook”=\>“db\_migrate”, “cmd”=\>[“su discourse -c ‘bundle exec rake db:migrate’”]}  
bootstrap failed with exit code 1  
\*\* FAILED TO BOOTSTRAP \*\* please scroll up and look for earlier error messages, there may be more than one.  
./discourse-doctor may help diagnose the problem.  
d1f6f36479328f22c8e65012eaf015046ecf28a07f0675911fdf6661704d2581  
root@determined-ptolemy:/var/www/vhosts/make.ooo/forum.make.ooo/discourse\_docker# /\>

---

_[View the full topic](https://meta.discourse.org/t/impossible-to-run-in-plesk-ubuntu-too-many-issues-eg-redis-network-connect/391360)._
