Incorrect Post can't be empty message when draft post navigated to user preferences


(Lee Dohm) #1

Repro Steps

  1. Click the Reply button to reply to this message
  2. Click your Gravatar in the button bar in the upper right of the page
  3. Select Preferences
  4. Enter enough text in the reply edit box to get past the minimum length/entropy restrictions
  5. Click the Reply button to post your reply

Expected: Reply posted without error message or message asking if you want to reply on the original topic
Actual: Error toast with the message “Post can’t be empty”

Notes

  • When typing in text in the edit control, nothing appears in the preview control
  • Assumption is that any administrative page may exhibit this behavior, but have not tested with anything but Preferences

Composing a message while on a user's preference page does not work
(Jeff Atwood) #4

I am guessing this is due to the “About Me” editor conflict on the page. I doubt you would see this on any other page.


(Jeff Atwood) #5

This should be fixed now.


(Jeff Atwood) #6