Incorrect URL generation after upgrading


(Ismael Olea) #1

Well. This is a bit stupid story about some people with an old Discourse installation in an old Ubuntu distro with an old Docker so the nice Discourse self updating system could not work anymore.

This old installation, which ran flawleslly, should be moved to another hosting. Instead to move the full VM->upgrading Ubuntu->upgrading Docker-> upgrading Discourse we just installed a fresh version and imported the full Discourse backup database from the old version.

At first sight this worked without no fuss, with joy and happiness for all us.

But. Oh. But. Things in life are not so easy.

Now we are suffering a nasty behaviour: when Discourse generates the system URL’s itself it adds automatically a :80 port into the URL. And as service is running under 443 causes wrong links:

My bet is we messed the database and we had that :80 encoded inside some databse field. We check several times the configuration UI but we can’t find any clue.

So, any idea of how to fix it? Rolling back to the original configuration is not vey attractive since we’d lost several weeks of activity.

Any guiding will be grateful.


(Jeff Atwood) #2

Are you using any weird proxying anywhere?

Definitely check site settings, it is definitely an error to put a port anywhere in the site settings in discourse, but I suspect this is external proxy shenanigans.