Instagram and Facebook oEmbed API to stop working, what about Onebox?

@znedw my question still stands, if you can help everyone with some insight on this please?

The first review failed because I had some extra text in the Oembed URL field and the form removes spaces onsubmit, so the URL didn’t work… That’s the only difference between attemps

Nope, in the Platform section (I had to add a platform in the wizard), I just wrote

No account needed

I didn’t really want to setup a discourse account just for FB review, so I just found a post on our forum that was public, and had an Instagram image embedded. I thought this would show how the integration functions well enough. I guess FB could read the discourse source and work it out themselves :man_shrugging:

Sorry I missed this. I literally did no changes to either forum, just found a forum post with an instagram pic embedded as mentioned above and then walked through the app review wizard on FB

3 Likes

Hi @znedw, I followed your guide and got our app review approved 24 hours later.

Although, I had to enter the direct link to the embedded Instagram post into the oEmbed-URL field as the form did not accept the link to the topic on our domain in that field. Maybe they changed that part.

For the rest, I followed exactly your wording. And it worked.

1 Like

@codinghorror
Instagram/Facebook embedding doesn’t work anywhere right now?
https://www.instagram.com/p/CS7GKY1lou-/

https://www.facebook.com/facebook/posts/410981573796774

1 Like

Let’s see – using the example from @jamie.wilson

https://www.instagram.com/p/CIRhYzFM7Lu

Looks like no – Facebook has basically removed this as a feature, sorry.

2 Likes

Nope, they have not. It’s just not (anymore) correctly configured here. Works like a charm on our Discourse with the same link you posted.

The embeds haven’t worked in Discourse since June

Like @Terrapop, that Instagram link you posted one boxes correctly on my forum too…

1 Like

There is no open graph metadata present on that Instagram URL:

Probably that request was made without a Facebook app access token.

1 Like

My bad, @jamie.wilson has pointed out that it does work, however Facebook didn’t approve our “app request” for dev, I think? So Facebook login must be configured on your Discourse instance for oneboxing to work now?

1 Like