Instagram videos autoplay with sound


(anonymous234) #1

Random example:

This gets translated to a < video style=“position:absolute; top:0; left:0; width:100%; height:100%” controls="" autoplay="">< /video>

I assume this is not intended, because it can be really annoying. Either the autoplay attribute should be removed, or the “muted” attribute added.

Edit: It doesn’t seem to work at all here. Apparently it just turns into a blank iframe. You should be able to see it here: Instagram autoplay with sound - What the Daily WTF?


(PJH) #2

Can we have a blacklist under /admin/site_settings/category/onebox as well as the whitelist?


(Jeff Atwood) #3

If you can’t repro it here (or on try), it’s not a bug, it is an issue with local site configuration.


(anonymous234) #4

Well I don’t know how that site is configured. But in any case, there is also a different bug here: instagram links show a preview in the post preview but become blank spaces in the actual post.


Instagram

EDIT: OK, that’s because this site is https but the video is served over http, so browsers block the mixed content.


(Jeff Atwood) #5

OK cool. Legit bug then. @techapj can you have a look when you get a chance?

Maybe we didn’t consider that instagram hosts videos as well as pictures…


(lid) #6

potentially there are two issues in this report

  1. Videos should not be autoplay by default

  2. When generating a onebox on a host that is https, prefer to use the :secure_url version of the media if provided.


(Jeff Atwood) #7

They aren’t autoplay by default – it’s some issue with instagram oneboxing.


(lid) #8

The issue will affect any video served via the default open graph oneboxing.

The embedding is simply achieved with an iframe and the src set to the media url
The browser auto generated video tag wrapper which unfortunately defaults to autoplay.

To solve this:
Videos served via the og protocol will need to be served via a custom wrapper / template.


(Jeff Atwood) #9

Let’s see:

http://vimeo.com/21644999

Thank your lucky stars that is not autoplaying. Maybe it’s an opengraph vs. oembed thing?


(Kane York) #10

I think it’s specific to Instagram - the returned <iframe> has autoplay on, so it will autoplay. Vimeo doesn’t return something with autoplay set, so it won’t.


(lid) #11

Vimeo is a custom player same like youtube. Instagram is a direct mp4 link.


(lid) #12

https://github.com/discourse/onebox/pull/242?merged


(Matches) #13

It’s definitely .mp4, my OBS videos do the same thing.


(Sam Saffron) #14

Autoplay no longer happening on try, so it looks likes the fix worked

Closing, flag to reopen if this is still an issue (old posts need to be rebaked to correct it)


(Sam Saffron) #15