Install Discourse on Ubuntu for Development


(paperless) #1

Hi all

I’m new to developing on discourse and have been following this guide to setup a development environment for Discourse.

However, I am facing a nasty issue which I have been trying to solve for hours trying to find people with the same issue but to no avail.

When I ran the script linked in the guide to download the necessary technologies, it failed on downloading postgresql (cut for brevity):

Setting up postgresql-common (188.pgdg16.04+1) …
dpkg: error processing package postgresql-common (–configure):
subprocess installed post-installation script returned error exit status 10
dpkg: dependency problems prevent configuration of postgresql-10:
postgresql-10 depends on postgresql-common (>= 182~); however:
Package postgresql-common is not configured yet.
dpkg: error processing package postgresql-10 (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-10; however:
Package postgresql-10 is not configured yet.

I figured it might be a PostgreSQL issue on Ubuntu but it seemed like other people are facing other issues pertaining to their problem and I am having a different problem. Can anyone assist me?

I am using Ubuntu 16.04 Xenial. Thank you!


(Jay Pfaffman) #2

See Backup has failed. pg_dump: server version: 9.6.3; pg_dump version: 9.5.10 for instructions on installing postgres 9.5.


(paperless) #3

Hi

Thanks for the reply.

I followed the steps and got this now:

The following information may help to resolve the situation:
The following packages have unmet dependencies:
postgresql-9.5 : Depends: libgssapi-krb5-2 (>= 1.14+dfsg) but 1.13.2+dfsg-5ubuntu2 is to be installed
Recommends: postgresql-contrib-9.5 but it is not going to be installed
Recommends: sysstat but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


(paperless) #4

Hi

Anyone available to help me with this issue?


(Sudaraka Jayathilaka) #5

Hi,
Are you trying to setup discourse dev environment for the first time ? Then this worked for me like a charm.


(paperless) #6

Hi

I tried this setup but I prefer to run the development environment in Linux as I use it more often :slight_smile:


(Andrew Schleifer) #7

Do you have any held packages?

Run dpkg --get-selections | grep hold to find out.