Install Problem on a Custom Server with Nginx

I have a server machine that is provided by a private vendor to the company. In this server, there is one website that is already operated using nginx, named as api.example.com. I tried all the suggestions here, I run "./launcher rebuild app --docker-args “–add-host extra.dns:8.8.8.8” command or this command "./launcher rebuild app --docker-args “–sysctl net.ipv6.conf.all.disable_ipv6=1 --sysctl net.ipv6.conf.default.disable_ipv6=1 --dns 1.0.0.1 --dns 1.1.1.1” or only “./launcher rebuild app”. But, for any case it didn’t work out everytime, it is the same problem, I got the following error.

    **I, [2019-07-04T06:03:25.662572 #16]  INFO -- : > cd /var/www/discourse && gem update bundler**
**ERROR:  While executing gem ... (Gem::RemoteFetcher::UnknownHostError)**
**    timed out (https://rubygems.org/specs.4.8.gz)**
**I, [2019-07-04T06:04:26.075400 #16]  INFO -- : **
**I, [2019-07-04T06:04:26.075885 #16]  INFO -- : Terminating async processes**
**I, [2019-07-04T06:04:26.076003 #16]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/10/bin/postmaster -D /etc/postgresql/10/main pid: 70**
**I, [2019-07-04T06:04:26.076089 #16]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 186**
**2019-07-04 06:04:26.076 UTC [70] LOG:  received fast shutdown request**
**186:signal-handler (1562220266) Received SIGTERM scheduling shutdown...**
**2019-07-04 06:04:26.092 UTC [70] LOG:  aborting any active transactions**
**2019-07-04 06:04:26.094 UTC [70] LOG:  worker process: logical replication launcher (PID 79) exited with exit code 1**
**2019-07-04 06:04:26.095 UTC [74] LOG:  shutting down**
**186:M 04 Jul 2019 06:04:26.175 # User requested shutdown...**
**186:M 04 Jul 2019 06:04:26.175 * Saving the final RDB snapshot before exiting.**
**186:M 04 Jul 2019 06:04:26.205 * DB saved on disk**
**186:M 04 Jul 2019 06:04:26.205 # Redis is now ready to exit, bye bye...**
**2019-07-04 06:04:26.253 UTC [70] LOG:  database system is shut down**


**FAILED**
**--------------------**
**Pups::ExecError: cd /var/www/discourse && gem update bundler failed with return #<Process::Status: pid 306 exit 1>**
**Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'**
**exec failed with the params {"cd"=>"$home", "hook"=>"web", "cmd"=>["gem update bundler", "find $home ! -user discourse -exec chown discourse {} \\+"]}**
**2ccd64cc0a831137458be59bf4cf19f0ab6fa75b86ba891effb3a8f12b02ab89**
**** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one**

And, I checked with tcpdump -i docker0 -n port 53 command, it again stuck the connection that is realted with rubygems.org… Here is result of tcpdump:

08:53:54.478415 IP 1.0.0.1.53 > 172.17.0.8.52862: 3398 0/1/0 (115)

08:53:56.808205 IP 172.17.0.8.48960 > 1.0.0.1.53: 31050+ A? rubygems.org. (30)

08:53:56.808235 IP 172.17.0.8.48960 > 1.0.0.1.53: 7332+ AAAA? rubygems.org. (30)

08:53:56.809944 IP 1.0.0.1.53 > 172.17.0.8.48960: 7332 1/0/0 AAAA 2a04:4e42::70 (58)

08:53:56.854069 IP 1.0.0.1.53 > 172.17.0.8.48960: 31050 4/0/0 A 151.101.192.70, A 151.101.0.70, A 151.101.64.70, A 151.101.128.70 (94)

I couldn’t figure this out, prior to Discourse forum, the company got forum.example.com already operating with Docker, what would be the problem here? Did I mess somethings up or is there any connection problem.

Thanks in advance.

Did you setup nginx and the app.yml as per this guide Running other websites on the same machine as Discourse?

Between that one above and this one Adding an offline page when rebuilding you should be able to setup everything you need to have Discourse running.

3 Likes

Yes I followed that guid you mentioned sir, but unfortunately I don’t have a happy ending.