Installation breaks on plugin addition


(Mihir) #1

My discourse installation breaks when I add a plugin in the config file. The logo and some other images disappears and returns 404.

The plugin I tried to add was the discourse sitemap plugin. It does not recover even if I remove the plugin.

I am running standard docker install.


(Bhanu Sharma) #2

Any errors in the terminal or /logs ?


(Mihir) #3

No errors on console.

The entire install does not break. I have noticed following two issues.
-some images, including the logo starts sending 404
-some URL redirects to repeat itself, like /t/2018/04 becomes /t/2018/042018/04


(Mihir) #4

BTW, Happy Birthday @itsbhanusharma


(Bhanu Sharma) #5

For the starters, can You please describe how you removed that plugin?
What version of discourse you were on when it happened?
I’d try to repro this at my sandbox tonight.

Also, Thanks for warm wishes :heart:


(Mihir) #6

Scratch that. The plugin has nothing to do with it.

I restored the entire VPS from backup, everything was working fine. I ran “rebuild” without any modification in the config file. There are no additional plugins.

One more thing - the web upgrade fails for plugins as well as discourse, it returns EACCES error with access denied for user rb_system. I don’t know if it has anything to do with this.


(Bhanu Sharma) #7

It definitely looks like a permissions issue. Have you modified any settings earlier? Or have you altered any user privileges?

I guess @pfaffman or someone from team can better explain this.


(Mihir) #8

Nothing at all. I followed simple docker installation guide. That’s it.