# Installation failing on CentOS 7.3

**URL:** https://meta.discourse.org/t/installation-failing-on-centos-7-3/58209
**Category:** Support
**Created:** [2017年三月2日 05:42 UTC](https://meta.discourse.org/t/installation-failing-on-centos-7-3/58209 "2017-03-02T05:42:39Z")
**Posts on this page:** 1
**Showing post:** 7

<div class="post-metadata">

### Author: ![mpalmer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mpalmer/32/45740_2.png) [@mpalmer](https://meta.discourse.org/u/mpalmer)
#### Post date: [2017年三月2日 06:26 UTC](https://meta.discourse.org/t/installation-failing-on-centos-7-3/58209/7 "2017-03-02T06:26:01Z")

</div>

> [@DanielMarquard](#):
>
> The best practice for using CentOS with EC2 is to use the officially-supported AMIs, so I’m not sure I have control over that.

Time to report a bug against that AMI, then.

> [@DanielMarquard](#):
>
> At least one of the issues in that post included a fix

The two issues linked to in [this post](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/20) were #9572 (filed in 2014 and not XFS specific) and #27358 which was acknowledged as not a Docker bug (and which led to the change to make it obvious in `docker info` that `Supports d_type: false`).

> [@DanielMarquard](#):
>
> I’m running into an unresolved issue

This is not a bug in Docker. You are running a configuration that does not work, and absent some changes to the kernel, _cannot_ work. Your options are as previously described in [this post](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/20).

---

_[View the full topic](https://meta.discourse.org/t/installation-failing-on-centos-7-3/58209)._
