# Installation Fails - Cannot change owner and permissions of ‘/shared/redis\_data’: No such file or directory

**URL:** https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440
**Category:** Self-hosting
**Created:** [25. Januar 2016 um 11:05 UTC](https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440 "2016-01-25T11:05:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Sashrika\_Waidyarathn](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@Sashrika\_Waidyarathn](https://meta.discourse.org/u/Sashrika_Waidyarathn)
#### Post date: [25. Januar 2016 um 11:05 UTC](https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440/1 "2016-01-25T11:05:46Z")

</div>

I am installing Discourse on a Cent OS 7 server. I am installing it in 3 different containers. After editing 3 .yml files I did

```shell
cd /var/discourse
./launcher bootstrap redis

```

But it gives me the following error. Can you please help me to sort this out. below is the full log. Thanks! Any help will be appreciated.

```
[isauser@discourse discourse]$ sudo ./launcher bootstrap redis
which: no docker.io in (/sbin:/bin:/usr/sbin:/usr/bin)
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2016-01-25T10:25:37.841253 #36] INFO -- : Loading --stdin
I, [2016-01-25T10:25:37.844193 #36] INFO -- : Skipped missing before_code hook
I, [2016-01-25T10:25:37.844248 #36] INFO -- : Skipped missing after_code hook
I, [2016-01-25T10:25:37.849694 #36] INFO -- : File > /etc/service/redis/run chmod: +x
I, [2016-01-25T10:25:37.853527 #36] INFO -- : File > /etc/runit/3.d/10-redis chmod: +x
I, [2016-01-25T10:25:37.853989 #36] INFO -- : Replacing daemonize yes with in /etc/redis/redis.conf
I, [2016-01-25T10:25:37.854588 #36] INFO -- : Replacing (?-mix:^pidfile.*$) with in /etc/redis/redis.conf
I, [2016-01-25T10:25:37.980491 #36] INFO -- : > install -d -m 0755 -o redis -g redis /shared/redis_data
install: cannot change owner and permissions of ‘/shared/redis_data’: No such file or directory
I, [2016-01-25T10:25:37.986631 #36] INFO -- : 

FAILED
--------------------
RuntimeError: install -d -m 0755 -o redis -g redis /shared/redis_data failed with return #<Process::Status: pid 42 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params {"cmd"=>["install -d -m 0755 -o redis -g redis /shared/redis_data"]}
7a7e9cc62623ddc0697c7f5657b715d6dd35ce54304e9024ba339495286c0679
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one
[isauser@discourse discourse]$

```

I did sudo ./launcher bootstrap data and got something similar to the above.

```
[isauser@discourse discourse]$ sudo ./launcher bootstrap data
which: no docker.io in (/sbin:/bin:/usr/sbin:/usr/bin)
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2016-01-25T11:11:57.231571 #37] INFO -- : Loading --stdin
I, [2016-01-25T11:11:57.238669 #37] INFO -- : Skipped missing before_code hook
I, [2016-01-25T11:11:57.238755 #37] INFO -- : Skipped missing after_code hook
I, [2016-01-25T11:11:57.239370 #37] INFO -- : > mkdir -p /shared/postgres_run
mkdir: cannot create directory ‘/shared/postgres_run’: Permission denied
I, [2016-01-25T11:11:57.248869 #37] INFO -- : 

FAILED
--------------------
RuntimeError: mkdir -p /shared/postgres_run failed with return #<Process::Status: pid 39 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "mkdir -p /shared/postgres_run"
1693d71e40524726af55162d80f2306367f2a19acae1f28ac74d7913861e19b7
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one
[isauser@discourse discourse]$

```

---

<div class="post-metadata">

### Author: ![wesochuck](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/wesochuck/32/108706_2.png) [@wesochuck](https://meta.discourse.org/u/wesochuck)
#### Post date: [26. Januar 2016 um 13:14 UTC](https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440/2 "2016-01-26T13:14:59Z")

</div>

Just guessing here, but did you check to make sure that there wasn’t already an instance of postgres on that machine? If you `cd` to those directories are they already there?

---

<div class="post-metadata">

### Author: ![Sashrika\_Waidyarathn](https://avatars.discourse-cdn.com/v4/letter/s/9d8465/32.png) [@Sashrika\_Waidyarathn](https://meta.discourse.org/u/Sashrika_Waidyarathn)
#### Post date: [27. Januar 2016 um 04:37 UTC](https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440/3 "2016-01-27T04:37:23Z")

</div>

Hi Wes, Thanks for the reply.  
No, the redis\_data directory had not created. we manually created it, but didn’t work. And the server doesn’t have any other postgres instance.

---

<div class="post-metadata">

### Author: ![Blaisorblade](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/blaisorblade/32/107357_2.png) [@Blaisorblade](https://meta.discourse.org/u/Blaisorblade)
#### Post date: [27. Januar 2016 um 05:30 UTC](https://meta.discourse.org/t/installation-fails-cannot-change-owner-and-permissions-of-shared-redis-data-no-such-file-or-directory/38440/4 "2016-01-27T05:30:26Z")

</div>

1. Can you check permissions of `/shared` _inside the container_?
2. Is `which: no docker.io in (/sbin:/bin:/usr/sbin:/usr/bin)` normal?
3. Could you include the container config (obscuring private info)?
4. But a _standard_ docker container contains its own postgres inside the cotainer, no?
