Installation problem with voting plugin


#1

Hello

The plugin seems installed as I can see it under plugins as v 0.4 and about 9 different plugin settings available…

However when I edit category, while I see additional options from other settings I do not see the allow voting checkbox. Any help with troubleshooting would be most appreciated.


(Joshua Rosenfeld) #2

Is the plugin enabled? Search for voting enabled in site settings.


#3

yes. i unselected and the reselected to make sure. same result unfortunately


(Geoff Hutchison) #4

I’m seeing the same problem. I have the plugin installed, voting is enabled, but I don’t see the option when editing category settings.


(Sam Saffron) #5

Can you try reproducing the issue?


(Joshua Rosenfeld) #7

On try.discourse.org I see Allow users to vote on topics in this category in category settings. I’ll test this on a non-hosted site too, but it appears to be working.

Edit: It works on a non-hosted install as well.


(Geoff Hutchison) #8

Is there any possibility of voting conflicting with other installed plugins? I have solved installed, much like the OP.

My use case is that I have support and development categories. I’d like to use solved in the support category, and voting in the development category.


(Joshua Rosenfeld) #9

Anything is possible, but I find it very unlikely it’s conflicting with another official plugin. We run the voting plugin along with a large number of other plugins internally.

Can you share the full list of plugins you’re running?


(Geoff Hutchison) #10

This is what I’ve got right now - everything is up-to-date.

discourse-details 0.4
doi-resolver 0.6
MathJax support for Discourse 0.4.1
discourse-narrative-bot 0.0.1
discourse-nginx-performance-report 0.1
discourse-presence 1.0
discourse-solved 0.1
discourse-voting 0.4
docker_manager 0.1
lazyYT 1.0.1
poll

(Geoff Hutchison) #11

I’m happy to get further debugging information if there’s something else needed.


(Joshua Rosenfeld) #12

Can you confirm which MattJax plugin that is? What’s the Github repo?


(Geoff Hutchison) #13

It’s this one: GitHub - kasperpeulen/discourse-mathjax: Mathjax plugin for discourse


(Joshua Rosenfeld) #14

Ah ha! Yes, there’s a very high chance that plugin is causing interference. That plugin is quite out of date. Please switch to GitHub - discourse/discourse-math: Official MathJax support for Discourse. More details can be found in Discourse Math Plugin (see “What about the old plugin?”)

Please do me a favor and switch to the current math plugin and let me know if the issue still exists.


(Geoff Hutchison) #15

Yeah, that seems to fix my problem at least.