# Internal Server Error 500- Manual configuration \[ Discourse AI\]

**URL:** <https://meta.discourse.org/t/internal-server-error-500-manual-configuration-discourse-ai/379557>\
**Category:** Support\
**Tags:** ai\
**Created:** [August 21, 2025, 6:32am UTC](https://meta.discourse.org/t/internal-server-error-500-manual-configuration-discourse-ai/379557 "2025-08-21T06:32:14Z")\
**Posts on this page:** 1\
**Showing post:** 1

<div class="post-metadata">

**Author:** ![viswanatha](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/viswanatha/32/518523_2.png) [@viswanatha](https://meta.discourse.org/u/viswanatha)\
**Post date:** [August 21, 2025, 6:32am UTC](https://meta.discourse.org/t/internal-server-error-500-manual-configuration-discourse-ai/379557/1 "2025-08-21T06:32:14Z")

</div>

I have a self-hosted Discourse forum, and I am encountering an Internal Server Error while configuring Discourse AI and the Manual LLMs. How can I resolve this issue? Could you please share any helpful guides to assist me further?

Error screenshots

 ![image](https://global.discourse-cdn.com/meta/original/4X/5/7/2/572f41ee2e3bb184ae245ec8ce63e85bea935109.png)

```plaintext
Failed to load resource: the server responded with a status of 500 ()

```

**screenshots Steps performed:**

 ![image](https://global.discourse-cdn.com/meta/original/4X/4/d/1/4d1847fda8066b13042197286c6a5138c2400885.png)  
 ![image](https://global.discourse-cdn.com/meta/original/4X/b/9/d/b9d3ce84ac8a8e4719802ae6c449e296fa6fe3e4.png)  
 ![image](https://global.discourse-cdn.com/meta/original/4X/a/5/b/a5bcc2fd864c99acf7c63bd9d7f3be1991bc1b81.png)  
 ![image](https://global.discourse-cdn.com/meta/original/4X/b/c/0/bc073ac7f6d785604794ccae856f42adbb33cd50.png)

---

_[View the full topic](https://meta.discourse.org/t/internal-server-error-500-manual-configuration-discourse-ai/379557)._
