IP address lookup failing


(Sebastian) #1

We’re having a bit of a problem on https://community.infinite-flight.com
Seems like the IP address lookup is partially failing.
As far as i can tell, it only fails to retrieve the location & ISP data of the IP address in question and duplicate accounts are displayed properly. I’m not 100% sure of the duplicate detection though, as i haven’t seen any recent lookup of new members displaying duplicate accounts and we usually have a few each day.

Seems to be the same regardless of IPv4 - IPv6.

Any ideas?

image

BR
Sebastian
IFC Moderator


#3

I also noticed this today in my site too,


(Jeff Atwood) #4

Hmm this is a legit regression @tgxworld


(cpradio) #6

I’m wondering if this is a regression or a scenario where the third party changed their implementation. As SP is experiencing this issue too, and I know for a fact we haven’t upgraded recently.


(Sam Saffron) #7

Good call, it is possible the 3rd party json api we are using for this recently changed implementation.

I am concerned somewhat that we have a URL to a 3rd party json API in core. There are pretty big security implications as well to this, cause we are effectively telling a 3rd party the IP addresses of our users.

I am mixed on pulling all of this into a plugin.


(Jeff Atwood) #8

Only on admin click, so I view this as a complete non-issue, especially since locating the IP is quite critical to some admin actions.


Password reset email should send IP info
(Sam Saffron) #12

Fixed per:


(Sam Saffron) #13