# IPv6 Git clone fallisce in discourse-setup, ma funziona sulla macchina?!?

**URL:** https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580
**Category:** Self-hosting
**Tags:** dev-install
**Created:** [30 Settembre 2023, 2:35am UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580 "2023-09-30T02:35:06Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![nottoobright](https://avatars.discourse-cdn.com/v4/letter/n/48db29/32.png) [@nottoobright](https://meta.discourse.org/u/nottoobright)
#### Post date: [30 Settembre 2023, 2:35am UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/1 "2023-09-30T02:35:07Z")

</div>

Il mio discourse-setup sta fallendo su un VPS Ubuntu 22.04 con il seguente errore:

fatal: unable to access [https://github.com/discourse/discourse.git/:](https://github.com/discourse/discourse.git/:) Could not resolve host: [github.com](http://github.com)

Il mio VPS ha solo un indirizzo IPv6, ma sto usando il proxy IPv6 di Dan Win per github: posso pingare [github.com](http://github.com), ho clonato con successo discourse\_docker.git e posso clonare l’esatto discourse.git dalla riga di comando sullo stesso VPS. Ma quando lo stesso comando viene eseguito da discourse-setup, non riesce a risolvere [github.com](http://github.com) e fallisce.

Un post precedente raccomandava di impostare mtu=1400 nel mio file docker.service, cosa che ho fatto, ma non ha cambiato nulla.

Inizialmente ho pensato che fosse un problema IPv6, ma il fatto che il mio VPS possa accedere a github e clonare il pacchetto mi confonde… non so cosa faccia diversamente la configurazione. Vorrei che ci fosse un modo per dire a discourse-setup che github.git è già sul server o semplicemente per usare le impostazioni predefinite del server che hanno funzionato.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [30 Settembre 2023, 11:34am UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/2 "2023-09-30T11:34:46Z")

</div>

> [@nottoobright](#):
>
> inizialmente ho pensato che fosse un problema IPv6, ma il fatto che il mio VPS possa accedere a GitHub e clonare il pacchetto mi confonde…

Sto ipotizzando che Docker non sia configurato per IPv6

---

<div class="post-metadata">

### Author: ![mcwumbly](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mcwumbly/32/103861_2.png) [@mcwumbly](https://meta.discourse.org/u/mcwumbly)
#### Post date: [30 Settembre 2023, 11:52am UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/3 "2023-09-30T11:52:24Z")

</div>

Ho riscontrato problemi con Docker su sistemi solo IPv6 in passato a causa della mancanza di NAT, poiché Docker utilizza spesso indirizzi IP accessibili solo dall’host ma il NAT non viene configurato automaticamente da Docker per IPv6.

Il readme di questo repository descrive il problema più dettagliatamente: [GitHub - robbertkl/docker-ipv6nat: Extend Docker with IPv6 NAT, similar to IPv4](https://github.com/robbertkl/docker-ipv6nat)

---

<div class="post-metadata">

### Author: ![nottoobright](https://avatars.discourse-cdn.com/v4/letter/n/48db29/32.png) [@nottoobright](https://meta.discourse.org/u/nottoobright)
#### Post date: [30 Settembre 2023, 8:33pm UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/4 "2023-09-30T20:33:08Z")

</div>

Sì, avete fatto centro: era effettivamente un problema di v6 perché Docker non gradisce v6. Ho aggiunto un indirizzo v4 al VPS e tutto ha funzionato.

Grazie

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [1 Ottobre 2023, 6:52pm UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/5 "2023-10-01T18:52:53Z")

</div>

> [@mcwumbly](#):
>
> In passato ho riscontrato problemi con Docker su sistemi solo IPv6 a causa della mancanza di NAT,

Ho sentito che esiste una grande azienda di hosting Discourse che utilizza ampiamente IPv6 nella propria infrastruttura.

Ma NAT sembra un problema probabile. Lo terrò a mente la prossima volta che giocherò con IPv6.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [31 Ottobre 2023, 6:53pm UTC](https://meta.discourse.org/t/ipv6-git-clone-fails-in-discourse-setup-but-works-on-the-machine/280580/6 "2023-10-31T18:53:34Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
