Is it OK to restore an older version backup on a newer install of Discourse?


(Sam Nguyen) #1

I found guideline as below link:

Ideally, both the new and old Discourses SHOULD BE ON THE EXACT SAME VERSION to ensure proper backup/export. So the first thing we’ll do is update our existing Discourse instance on Linode to the absolute latest version.

Because my old server’s disk is full which have free space only 4GB, So I cannot upgrade to lasted version of discourse. My discourse version is v2.2.0.beta3 +100 and lasted version is 2.2.0.beta4

So can I restore backup from old server to new server which will be setup lasted version of discourse?

Or there are any way to install v2.2.0.beta3 +100 in my new server?

Many thanks.


(Stephen) #2

Have you tried doing:

cd /var/discourse
./launcher cleanup 

to make some more space on the original server?


(Sam Nguyen) #3

Thank you for reply.

Yup, I tried and disk space free 4.1GB :frowning:


(Stephen) #4

Then I would try to restore from that version to latest. Until you hit an error there’s not much point worrying.


(Sam Nguyen) #5

I cannot get what you mean.

My old server still beta3 version of discourse.

Do you mean I can restore from beta3 to lasted without any problem?


(Stephen) #6

It can’t hurt to try, particularly if you can’t make space to complete the upgrade on your origin server.

Personally I would be trying to make room. What’s using all the disk?


(Jeff Atwood) #7

This is only a recommendation, that is why it says “ideally”. It should still work, as long as you are migrating from older → newer version of Discourse, obviously.


(Sam Nguyen) #8

Yeah, many thanks.

I have just restore. But there have a small bug:

I going to admin panel, and it show me have update although I had installed lasted update before restore. So I think there is old information of old server.

I tried update by connect my server via ssh and run command below:

        cd /var/discourse
        git pull
        ./launcher rebuild app

After done, I double check via admin panel, I still old version and ask me update?

So how can I do to fix it?

many thanks.


(Stephen) #9

Are you sure you’re looking at the new site? Is DNS updated and replicated?


(Sam Nguyen) #10

okie sorry my fault.

Many thanks team, My website working normally.

cheer.