Is it possible not to display Site statistics in Page" About"?


(RCASE) #1

Hi All,

I am looking for a how to not display Site Statistics in the Page “About”.
I searched a question similar but i didn’t find.
Thanks for help


(RCASE) #2

Hello,

Have you got any idea about how to customize the Page “About” and above all avoid displaying Site global statistics ?

Best regards


(Jeff Atwood) #3

You could add CSS styles in Admin, Customize to suppress the table.


(RCASE) #4

Is there a tutorial explaining how that could be done ? I don’t want to crash my discourse forum. Besides, I would like to customize signup form , for example suppress the label “Your full Name” that disturbs a few users unfortunately…


(Kane York) #5

Don’t worry, the CSS styles aren’t applied to the admin section! And if you screw up the syntax, the errors will be in a footer:after rule, which will be visible on the bottom of all the pages. The rest of the customizations will be gone, and it will look bad, but it will still be usable.


(RCASE) #6

Hi All

@riking

I added this CSS in the admin section

section.about.stats {
display : none;
}

to suppress Statistic table on Page “About” but sometimes the Statistics table is displayed whereas i made cache empty.

Another question : In signup modal screen , how could I change the label for the full name and replace “Your full name” by "Your Full Name (not shown publicly to the members) "

Thanks


(Kane York) #7

Did you make sure:

  1. The stylesheet is “Enabled”?
  2. There is only one “Enabled” stylesheet?
  3. You clicked “Remove preview” after you were done editing?

This could be done with either a translation override (hopefully will get that at some point) or a CSS :after rule.


(RCASE) #8

Everything is ok now when I refresh the page. Don’t know what was wrong.

I don"t understand your translation override and I don’t find what css item corresponds to label “Your full name” in signup modal page.
What is more recommended between both ?

Thanks


(RCASE) #9

Hi, I used this CSS :after rule in Admin section

.create-account tr.instructions label:after
{content:“Never shown to the public.”}

But the content is added for all the inputs of signup page instead of only “Name” input.

What is wrong with my CSS rule ?
Thanks


(Kane York) #10

Try :nth-of-type(3) or whatever number is correct


(RCASE) #11

Unfortunately it doesn’t work .The content is still added for all the labels of the inputs in signup page instead of only the label of the “Name” input.

I tried this css rule:
.create-account tr.instructions label:nth-of-type(1):after
{
content:“Never shown to the public.”
}

Thanks


(RCASE) #12

Hi all,

@riking have you got an idea ?

Anyone may have an issue ?

Thank you


(Mittineague) #13

I Don’t know which you’re still looking for, this?
section[class="about stats"] { display: none; }


(RCASE) #14

Hi ,

This point has been solved. I opened the other problem in a new topic How to customize label after “Input Name” in Signup Page .

Thank you.


(system) #15

(Régis Hanol) #16