Is it supposed to be possible to upload images via email?


(Dave Eargle) #1

Is it supposed to be possible for users to reply to posts with images, and for those images to show up in their post? I had a user send in two images via email, and they got uploaded, but all that showed in his post was the following:

[/uploads/default/original/1X/139d611a07adf85a<snip>.jpg]

[/uploads/default/original/1X/f730b788b5d3f531a4<snip>.jpg]

And I can manually browse to those images. I was on v2.0.0.beta1 I think.

I then upgraded discourse to v2.0.0.beta3 +11, did a test post, using gmail, and my incoming image only showed the alt tag on discourse, like this:

[image: Image result for business cat]

FWIW I can successfully upload images via the browser, and those images get sent out via email, and show up in emails.


(Jeff Atwood) #2

Just tested an email reply here with image and it worked fine — see picture proof


(Dave Eargle) #3

Something to do with the email client. Tested again, it worked when I used gmail, didn’t work when I used Google Inbox (showed the alt tag instead again).


(Sam Saffron) #4

Can you reply to this message via your email client with an example failure?


(DanielMorgan) #5

Also hitting this issue. Might have something to do with inline images (hosted with an absolute URL) vs ‘attachments’? On version 1.9.3.


(Dave Eargle) #6

These are the two images I was testing with. I’m sending from Google Inbox, images inline.

Image result for BUSINESS CAT


(Dave Eargle) #7

Hmm looks like it worked, so that means it’s something particular to my install. I’m using Dovecot for inbound.


(Régis Hanol) #8

Can you PM the raw version of an incoming email that’s failing?


(Dave Eargle) #9

I sent a PM, thanks.


(Dave Eargle) #10

Reporting back, had to have both download remote images to local and incoming email prefer html enabled. Then inline images appear. @zogstrip noticed that the inline images only appear in the HTML version of the email as <img src> tags, not the TXT version.


(Jeff Atwood) #11

Hmm, @zogstrip and @gerhard shouldn’t we default “incoming email prefer html” to ON by now? I think we should…


(Gerhard Schlager) #12

It has been enabled on meta for a long time and it’s working quite well. So, yeah, enabling it by default makes sense.

Done: FEATURE: Use HTML instead of text for incoming emails by default · discourse/discourse@210939d · GitHub