Is Ruby 2.5 a hard requirement for current Discourse releases?

I have an unsupported scenario where I need to run Discourse with Ruby 2.4.9p362. Is this doable without modifying the Gemfile and other dependencies?

Additionally, what negative effects could potentially be observed in this scenario?

1 Like

Only supported way of using Discourse is following the which will use Ruby 2.6.5 currently.

Other Ruby versions aren’t supported, and may not work and fail in subtle ways.


Right, that is why I qualified this as being unsupported. I was hoping someone may know of (un)subtle ways that might occur with Ruby 2.4.9p362 as noted. Docker installation is also not an option for me. But being a developer myself, I can wade in these waters, just good to know details where possible. :slight_smile:

1 Like

There is a hard check in the code.