Issue with create new account using Google authentication


(Dave McClure) #1

Just had a new user report this issue.

Our forum is currently set up to

  • require login to view topics
  • require approval for new user accounts

A new user attempted to sign up with their Google account by doing:

  • Sign in
  • Sign in with google
  • Create new account

They filled in all the fields, and all fields validated

But on hover over ‘Create Account’ it was not click-able.

As a workaround, I had them just create the account manually using the same email address (I think they should be able to authenticate with google later). Their email address is not @gmail.com its a google apps account.

I am almost positive I was able to do this earlier with two other google apps accounts though… We are on the latest commit of master now:


(Kane York) #2

There’s also a critical issue with Google authentication - maybe this is related? I got this error too in the last few days, but refreshing seemed to fix it.

https://meta.discourse.org/t/openid-auth-request-contains-an-unregistered-domain/15843/7?u=riking&source_topic_id=15847

(Neil Lalonde) #3

I’m sure I fixed that. The button will never be disabled anymore. Are you sure you’re on the latest commit?


(Dave McClure) #4

I’m currently 3 commits behind. The first time he tried logging in I was maybe a couple days behind or so (sorry I didn’t make note of that). But then I updated and we tried again. (Maybe he tried again before the update was complete?)

I’ll try to reproduce later with another account.

EDIT: I cannot reproduce this issue


(Jeff Atwood) #5

This topic was automatically closed after 24 hours. New replies are no longer allowed.