# Issues with AWS CDN and S3

**URL:** https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132
**Category:** Self-hosting
**Tags:** cdn, s3
**Created:** [December 10, 2025, 3:15am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132 "2025-12-10T03:15:44Z")
**Posts on this page:** 20
**Page:** 1

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 10, 2025, 3:15am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/1 "2025-12-10T03:15:44Z")

</div>

> [@Configure an S3 compatible object storage provider for uploads](https://meta.discourse.org/t/configure-an-s3-compatible-object-storage-provider-for-uploads/148916/1):
>
> ### AWS S3
> 
> What we officially support and use internally.

@Falco I this still the case? I thought I read something about recent issues using AWS but I can’t find the topic again.

I am having numerous using AWS S3 using the various relevant topics as guides.

Backups are working as expected but using Cloudfront as CDN or uncommenting DISCOURSE\_USE\_S3 and/or DISCOURSE\_S3\_BUCKET causes a perpetual throbber to happen.

I suspect I have something misconfigured in the uploads bucket and/or the Cloudfront distribution but I have not been able to find a mistake. Both upload and backup buckets are behind the distribution and backups work fine so???

[discourse-cdn.repealobbba.org](http://discourse-cdn.repealobbba.org) CNAME —\> [amazonassigned.cloudfront.net](http://amazonassigned.cloudfront.net)

DISCOURSE\_CDN\_URL: [https://discourse-cdn.repealobbba.org](https://discourse-cdn.repealobbba.org)

```plaintext
## S3 storage config
# DISCOURSE_USE_S3: true
  DISCOURSE_S3_REGION: us-east-1
  DISCOURSE_S3_ACCESS_KEY_ID: ACCESS_KEY_ID
  DISCOURSE_S3_SECRET_ACCESS_KEY: SECRET_ACCESS_KEY
  DISCOURSE_S3_CDN_URL: amazonassigned.cloudfront.net or
# DISCOURSE_S3_BUCKET: repeal-obbba-discuss-uploads
  DISCOURSE_S3_BACKUP_BUCKET: repeal-obbba-discuss-backups
  DISCOURSE_BACKUP_LOCATION: s3

```

**Additionally** , adding this to config

```plaintext
    after_assets_precompile:
    - exec:
        cd: $home
        cmd:
          - sudo -E -u discourse bundle exec rake s3:upload_assets
          - sudo -E -u discourse bundle exec rake s3:expire_missing_assets

```

Gives FAILED TO BOOTSTRAP error

```plaintext
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && sudo -E -u discourse bundle exec rake s3:upload_assets failed with return #<Process::Status: pid 8484 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.3.0/lib/pups/exec_command.rb:131:in `spawn'
exec failed with the params {"cd"=>"$home", "cmd"=>["sudo -E -u discourse bundle exec rake s3:upload_assets", "sudo -E -u discourse bundle exec rake s3:expire_missing_assets"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.

```

as always… **Any thoughts or suggestions would be appreciated.**

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 10, 2025, 12:35pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/2 "2025-12-10T12:35:05Z")

</div>

> [@philh](#):
>
> uncommenting DISCOURSE\_USE\_S3 and/or DISCOURSE\_S3\_BUCKET causes a perpetual throbber to happen.

You need to add the stanza that uploads assets to s3.

Oh. I’m wrong, you’re doing it.

> [@philh](#):
>
> Gives FAILED TO BOOTSTRAP error

That suggests something is wrong with the bucket configuration.

I think there used to be a topic that would generate the json to configure a bucket, but I don’t know if it’s still around.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 10, 2025, 10:22pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/3 "2025-12-10T22:22:30Z")

</div>

> [@pfaffman](#):
>
> That suggests something is wrong with the bucket configuration.

Agreed  
Although a bucket policy was not used on backups bucket a adding a policy to uploads bucket cleared the bootstrap failure.

The policy json is available at CloudFront\>Distributions\>your distribution\>Edit origin  
 ![Screenshot 2025-12-10 141220](https://global.discourse-cdn.com/meta/optimized/4X/3/3/d/33d5a609fceedea6e712f5bc60f115f3ffe042cd_2_690x41.png)

Unfortunately the perpetual throbber persists.

Adjusting Object Ownership and ACLs does not change result.

 ![Screenshot 2025-12-10 141936](https://global.discourse-cdn.com/meta/original/4X/0/d/0/0d0ef7dbd85570599928317a1d805bd6405468bb.png)

Current settings. I believe they are the recommended settings or perhaps I am confused.

 ![Screenshot 2025-12-10 141702](https://global.discourse-cdn.com/meta/original/4X/4/9/a/49a8a7f7eb092ab4ea076da584bcbffd0ba37040.png)  
 ![Screenshot 2025-12-10 141835](https://global.discourse-cdn.com/meta/original/4X/2/c/5/2c5152a2890978334eadacb0d098339439b501ce.png)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 11, 2025, 2:48am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/4 "2025-12-11T02:48:11Z")

</div>

After you change the settings you need to run the rant task to upload the the assets.

Also, you can open the developer console and see if the files is trying to access exist on the bucket or if there’s an issue with the cdn

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 11, 2025, 3:51am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/5 "2025-12-11T03:51:56Z")

</div>

Thanks for continuing…

Yes, rake tasks are run, makes no difference.

./launcher enter app  
rake posts:rebake  
rake uploads:migrate\_to\_s3  
rake posts:rebake\_uncooked\_posts

**Throbber persists.**

rake uploads:migrate\_to\_s3 does yield an error

```plaintext
Migrating uploads to S3 for 'default'...
Some uploads were not migrated to the new scheme. Running the migration, this may take a while...
rake aborted!
FileStore::ToS3MigrationError: Some uploads could not be migrated to the new scheme. You need to fix this manually. (FileStore::ToS3MigrationError)
/var/www/discourse/lib/file_store/to_s3_migration.rb:156:in `migrate_to_s3'
/var/www/discourse/lib/file_store/to_s3_migration.rb:59:in `migrate'
/var/www/discourse/lib/tasks/uploads.rake:126:in `migrate_to_s3'
/var/www/discourse/lib/tasks/uploads.rake:106:in `block in migrate_to_s3_all_sites'
/var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rails_multisite-7.0.0/lib/rails_multisite/connection_management/null_instance.rb:49:in `with_connection'
/var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rails_multisite-7.0.0/lib/rails_multisite/connection_management/null_instance.rb:36:in `each_connection'
/var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rails_multisite-7.0.0/lib/rails_multisite/connection_management.rb:17:in `each_connection'
/var/www/discourse/lib/tasks/uploads.rake:104:in `migrate_to_s3_all_sites'
/var/www/discourse/lib/tasks/uploads.rake:100:in `block in <main>'
/usr/local/bin/bundle:25:in `load'
/usr/local/bin/bundle:25:in `<main>'
Tasks: TOP => uploads:migrate_to_s3

```

At least one CDN checker shows [discourse-cdn.repealobbba.org](http://discourse-cdn.repealobbba.org) --\>Amazon CloudFront

and console still shows images and js files are being called from the CDN

 ![Screenshot 2025-12-10 192413](https://global.discourse-cdn.com/meta/original/4X/8/b/2/8b2d0be30fa289b4050e3d998d26daa05a5607d3.png)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 11, 2025, 10:30am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/6 "2025-12-11T10:30:03Z")

</div>

The assets are called from the cdn, but are they there? If not, are they in the bucket? Are they accessible from the bucket?

You likely have some uploads in a different bucket or something that keeps them from being in the expected place. If so, you’ll need to fix those by hand like it sats. You’ll need to access the console and see where they are on the upload record.

Does the upload assets task seem to be working? The throbber keeps running because the other assets are no loading.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 11, 2025, 7:00pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/7 "2025-12-11T19:00:14Z")

</div>

Yes they are there, files are in the bucket as assets  
Accessible: [https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com/assets/logo-815195ae.png](https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com/assets/logo-815195ae.png)

Only two buckets, uploads and backups. Backups are working fine.

rake s3:upload\_assets gave error:  
rake aborted!  
Aws::S3::Errors::AccessControlListNotSupported: The bucket does not allow ACLs (Aws::S3::Errors::AccessControlListNotSupported)

Switched to ACLs enabled and ran _s3:upload\_assets_ **edit: uploads:migrate\_to\_s3** again but…  
FileStore::ToS3MigrationError: Some uploads could not be migrated to the new scheme. You need to fix this manually. (FileStore::ToS3MigrationError)

??? You need to fix this manually. (FileStore::ToS3MigrationError)

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 11, 2025, 7:05pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/8 "2025-12-11T19:05:24Z")

</div>

It sounds like you fixed the bucket and it’s now able to upload assets, so the site should work now. Dealing with the uploads that won’t migrate is another (complicated) issue.

Here’s one of the assets you’re trying to serve:

```plaintext
https://discourse-cdn.repealobbba.org/assets/start-discourse-6f03a463.br.js

```

The cert is broken, so that’s your problem. There is a cert, but it doesn’t match the URL.

As I suggested earlier, look at the network tab of the dev tools in your browser and see this:

 ![image](https://global.discourse-cdn.com/meta/original/4X/8/f/6/8f6266647707a0166b429eefa3765763e4f66b19.png)

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 11, 2025, 7:14pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/9 "2025-12-11T19:14:47Z")

</div>

edit from above  
Switched to ACLs enabled and ran _s3:upload\_assets_ **edit: uploads:migrate\_to\_s3** again

s3:upload\_assets completes without issues now

I see the network errors. Is the cert an AWS issue?

Thanks again for your time on this!!

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 11, 2025, 7:21pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/10 "2025-12-11T19:21:45Z")

</div>

> [@philh](#):
>
> I see the network errors. Is the cert an AWS issue?

Yes. The cert doesn’t match the host name. It matches `*.cloudfront.net`

This works: `https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com/assets/logo-815195ae.png`

This does not work: `https://discourse-cdn.repealobbba.org/assets/start-discourse-6f03a463.br.js`

This works: `https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com/assets/start-discourse-6f03a463.br.js`

So you need to change your s3 CDN to `https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com` – oh, I guess that’s the bucket address, so that wouldn’t be ideal, but it would work.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 11, 2025, 7:52pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/11 "2025-12-11T19:52:20Z")

</div>

> [@pfaffman](#):
>
> So you need to change your s3 CDN to `https://repeal-obbba-discuss-uploads.s3.us-east-1.amazonaws.com` – oh, I guess that’s the bucket address, so that wouldn’t be ideal, but it would work.

Not to keen on “so that wouldn’t be ideal” 😉

Looking at AWS Alternate domain names as a possible solution.

 ![Screenshot 2025-12-11 113613](https://global.discourse-cdn.com/meta/original/4X/1/1/3/11342feff6878f7feaa12e6880fdc8020a7a603d.png)

Maybe it is just me but adding a CDN that @Discourse uses internally should maybe not be so difficult and require the kind support from folks like @pfaffman

Maybe @Falco or @sam and [@team](https://meta.discourse.org/groups/team) (can’t mention team) can chime in??

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [December 11, 2025, 9:21pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/12 "2025-12-11T21:21:03Z")

</div>

> [@philh](#):
>
> @Falco I this still the case?

Yes, all the sites we host use the S3 plus CloudFront combo. Even this site you are browsing right now.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 11, 2025, 9:39pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/13 "2025-12-11T21:39:09Z")

</div>

Thanks for confirming! After seeing this I re-adjusted DISCOURSE\_S3\_CDN\_URL: back to [amazonassigned.cloudfront.net](http://amazonassigned.cloudfront.net) hoping it my clear the cert and url issues.

 ![Screenshot 2025-12-11 133250](https://global.discourse-cdn.com/meta/original/4X/0/6/c/06cb19faee51637a57a93f6db8b966434732f135.png)

The rebuilt and re ran all the rakes mentioned in docs.  
rake posts:rebake  
rake uploads:migrate\_to\_s3 **still generates FileStore::ToS3MigrationError**  
rake posts:rebake\_uncooked\_posts

rake s3:upload\_assets  
rake s3:expire\_missing\_assets

Still no joy on getting the site to load.

Any suggestions?

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 12, 2025, 8:19am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/14 "2025-12-12T08:19:55Z")

</div>

> [@philh](#):
>
> Looking at AWS Alternate domain names as a possible solution.

Turns out this was helpful.

 ![Screenshot 2025-12-12 001849](https://global.discourse-cdn.com/meta/original/4X/5/7/7/5772ca8bc249c0541b15f8ec560305c46301ea95.png)

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 12, 2025, 5:44pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/15 "2025-12-12T17:44:14Z")

</div>

@chapoi kindly split this thread to support  
Perhaps @JammyDodger moved to Installation perhaps for better visibility although the forum has been running fine for many months.

Anyway, thanks for the attention!

---

<div class="post-metadata">

### Author: ![Moin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/moin/32/554653_2.png) [@Moin](https://meta.discourse.org/u/Moin)
#### Post date: [December 12, 2025, 5:46pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/16 "2025-12-12T17:46:14Z")

</div>

> [@philh](#):
>
> although the forum has been running fine for many months.

Installation is not only for setting up the forum

> **[Self-hosting](https://meta.discourse.org/c/support/self-hosting/31)**
>
> Getting self-hosted Discourse sites up and running, keeping them going, updating them, and any other general sysadmin maintenance.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 12, 2025, 5:57pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/17 "2025-12-12T17:57:32Z")

</div>

Copy that, thanks for the clarification.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 12, 2025, 8:20pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/18 "2025-12-12T20:20:52Z")

</div>

As mentioned above, add an alternative domain help.  
The site loads but without stylesheets and…

> **[Repeal OBBBA Forum](https://forum.repealobbba.org/)**
>
> Repeal the One Big Beautiful Bill Act - Information, discussion, stories, impact AND accountability.

Looking in the bucket I don’t see stylesheets/ folder

 ![Screenshot 2025-12-12 120937](https://global.discourse-cdn.com/meta/original/4X/d/0/e/d0ef86901fe68d30a62586555eaac03dfd2ec8ec.png)

Seems s3:upload\_assets is incomplete.

And there is a CORS issue?

 ![Screenshot 2025-12-12 121734](https://global.discourse-cdn.com/meta/original/4X/7/b/8/7b8e76b4a2ad2caf4d84da11371820bf45da9b13.png)

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 14, 2025, 9:06am UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/19 "2025-12-14T09:06:03Z")

</div>

Making progress after getting my head around a few things in the docs that were either misleading, confusing or just too much for someone that has BBS. 🫪

For us BBS folks putting this in flashing red would help convey “ **you will need two Cloudfront distributions** ”.

> [@Configure an S3 compatible object storage provider for uploads](https://meta.discourse.org/t/configure-an-s3-compatible-object-storage-provider-for-uploads/148916/1):
>
> DISCOURSE\_CDN\_URL is a CDN that points to you Discourse hostname and caches requests. It will be used mainly for pullable assets: CSS and other theme assets.
> 
> DISCOURSE\_S3\_CDN\_URL is a CDN that points to your object storage bucket and caches requests. It will be mainly used for pushable assets: JS, images and user uploads.

and some instruction on how to

> [@Configure an S3 compatible object storage provider for uploads](https://meta.discourse.org/t/configure-an-s3-compatible-object-storage-provider-for-uploads/148916/1):
>
> We recommend those being different and for admins to set both.

Some updating and consolidating of S3 related topics would be very cool. I think one master topic with current data for AWS S3 CDN and Backups would be awesome.

moving on…

I have two Cloudfront distributions now but:

- The throbber persists [https://discuss.repealobbba.org/](https://discuss.repealobbba.org/)
- Some assets are not visible in the uploads bucket
- some assets are trying to load in the backups bucket
- obvious numerous erorrs in console i.e. The resource at “[https://discourse-cdn.repealobbba.org/stylesheets/common\_theme\_6\_1f8270be80babb5906f2dfb4fa157b7d9f9d12f8.css?\_\_ws=discuss.repealobbba.org”](https://discourse-cdn.repealobbba.org/stylesheets/common_theme_6_1f8270be80babb5906f2dfb4fa157b7d9f9d12f8.css?__ws=discuss.repealobbba.org%E2%80%9D) was blocked by OpaqueResponseBlocking. **Reason: “after sniff: status code is not in allowed range”.**
- I am not certain my implementation of two distributions is correct.

All the rakes execute without error and  
and this no longer causes a bootstrap failure.

```plaintext
after_assets_precompile:
    - exec:
        cd: $home
        cmd:
          - sudo -E -u discourse bundle exec rake s3:upload_assets
          - sudo -E -u discourse bundle exec rake s3:expire_missing_assets

```

CDN checker looks more like a desirable result

 ![Screenshot 2025-12-14 004220](https://global.discourse-cdn.com/meta/original/4X/0/f/5/0f54f458a35de3def080f27d1c1e307dd93a8859.png)

All in all progress but some tips from the Discourse infrastructure team would be very helpful.

---

<div class="post-metadata">

### Author: ![philh](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/philh/32/532740_2.png) [@philh](https://meta.discourse.org/u/philh)
#### Post date: [December 20, 2025, 8:11pm UTC](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132/20 "2025-12-20T20:11:17Z")

</div>

Whew! It took a ton of time and some hours (8 over 2 calls) on the phone with a very helpful Amazon engineer but I think I have my head around this. Things are working great on the RepealOBBBA site and my process is reproducible to other sites.

I may write things up but a few notes for now:

1. DISCOURSE\_CDN\_URL (if using AWS S3) and DISCOURSE\_S3\_CDN\_URL require their own Cloudfront distributions.
2. DISCOURSE\_CDN\_URL does not use a bucket.
3. DISCOURSE\_CDN\_URL can be a nonAWS CDN. [Bunny.net](http://Bunny.net) works great. (I am told Bunny Storage with S3 support is due out 2026 1st quarter)
4. DISCOURSE\_CDN\_URL and DISCOURSE\_S3\_CDN\_URL CDNs can be branded urls with the appropriate DNS config.
5. DISCOURSE\_S3\_CDN\_URL requires an uploads bucket.
6. The uploads bucket requires ACLs enabled and “Everyone (public access)” set to “Read” and you must set a policy for the bucket.
7. The backups bucket does not require ACLs or policy.

Edit(s)

1. Check the box in S3 use CDN URL for all uploads: Use CDN URL for all the files uploaded to s3 instead of only for images. Not enabling always caused failures for me.  
 ![Screenshot 2025-12-20 122637](https://global.discourse-cdn.com/meta/original/4X/9/2/7/9270c2750e0edce9e7f9160bb63d3394d774f78a.png)

I imagine many may read the above and go duhhh Phil, no kidding, that is obvious but… my BBS head did not get it right away.

[Next page](https://meta.discourse.org/t/issues-with-aws-cdn-and-s3/391132.md?page=2)
