Jobs::CleanUpUploads failing


(Michael Downey) #1

Continuing the discussion from Constantly getting sidekiq errors “Jobs::CleanUpUploads”:

FWIW, my job was failing as well. I toggled it off, triggered the sidekiq job, and it succeeded. However, when I re-enabled the site setting, triggered the job again, it was once again failing.


(Sam Saffron) #2

anything in /logs ?


(Michael Downey) #3

Wow, I just learned this was a thing. Thank you! :thumbsup:

Anyway, looks like a series of two errors repeating periodically:

  1. [Ruby] exception: PG::Error: ERROR: column "system_upload_id" does not exist LINE 1: - Pastebin.com
  2. [Ruby] PG::Error: ERROR: column "system_upload_id" does not exist LINE 1: ...oad_id f - Pastebin.com

(Sorry, tried to actually paste the full errors here but formatting was too much of a pain. :-))


(Sam Saffron) #4

looks like migrations did not run properly try

cd /var/docker
git pull
./launcher rebuild app

(Jeff Atwood) #5

Why? Select the block then press CTRL+k, which is also printed on the tooltip for the code button in the editor toolbar.

Or select the block and click or tap the code button in the editor toolbar.


(Michael Downey) #6

Did this, but still the same pair of errors in the logs, even after toggling the site setting off and on (and saving each). Triggering the job still results in FAILED status.

When you try to do two code snippets next to each other, they keep merging into one big block and I was getting tired of fighting it with such scrolling. (And I was trying to rush out the door.)

(As an aside, I just discovered you can drag the bottom panel up to make it larger. It might be nice if there were some visual affordance there to indicate it.)


Visual indication of editing panel resizability
(Sam Saffron) #7

ok, just fixed it, can you upgrade?


(Michael Downey) #8

That worked. Thank you!


(Sam Saffron) #9