Just launched Discourse and i need help on how to Update it..?

unsupported-install

(john hashim) #1


(Jeremy M (Jerdog)) #2

Go to the /admin/docker or /admin/upgrade page and you’ll be set. There isn’t a link there, you’ll have to manually go there.


(Jeff Atwood) #3

Per previous discussion this is likely an unsupported install so that probably won’t work.


(Jeremy M (Jerdog)) #4

Yep. Answered this one first then saw the other


(john hashim) #5

what do you mean ? you dont support bitnami?


(Mittineague) #6

Please see

discourse/INSTALL.md at master · discourse/discourse · GitHub

The only officially supported installs of Discourse are Docker based. You must have SSH access to a 64-bit Linux server with Docker support. We regret that we cannot support any other methods of installation including cpanel, plesk, webmin, etc.

Why do you only officially support Docker?

Hosting Rails applications is complicated. Even if you already have Postgres, Redis and Ruby installed on your server, you still need to worry about running and monitoring your Sidekiq and Rails processes, as well as configuring Nginx. With Docker, our fully optimized Discourse configuration is available to you in a simple container, along with a web-based GUI that makes upgrading to new versions of Discourse as easy as clicking a button.