Large cookie breaks site

I have an install where the forum is on a subdomain of the main web site, so they’re sharing the same primary domain. I set a cookie on the main web site that is on the large side. If I then try and go to the forum site in Edge (works in Chrome, Firefox, etc.) it breaks and says it can’t reach that page. If I delete the cookie, the site loads fine. I need the cookie to be on the root domain as it’s shared among other sub-domains but it’s not actually used on the forums. I tried adjust nginx settings to allow large headers, but that hasn’t made a difference. Any idea what I need to do here (other than not use edge and/or use a smaller cookie)?

Example:
On www.example.com, set cookie MyBigCookie=3+k value using domain = .example.com.
Go to forums.example.com in Edge - site is unreachable.

1 Like

Doesn’t the nginx have maximum default cookie sizes? You might need to change that in the nginx config in the Discourse container.

2 Likes

Already tried those. Unfortunately it didn’t make a difference.

1 Like

I was able to adjust my cookie size to work around it for now.

5 Likes