Latest Update - Official Ad Plugin Broke Site


#1

I did the one-push upgrade this morning and once the upgrade was complete, I was greeted with a white page with a warning on it indicating that the plugin had failed. I should have taken a screenshot but was in a rush. I just went in, deleted the plugin, and rebuilt. No issues after that.

I’ll try to recreate the issue soon - I just prefer not having a whole lot of down time. Wanted to share this with the group for awareness.


(Jeff Atwood) #2

Unlikely as we ship this plugin on our hosting, and have for some time.


#3

It’s probably the issue that @neil fixed here:


#4

Looks like this issue is still around. This upgrade from the Admin:

from_version: 3388cc0, e101e6a, 297aefc
repository: /var/www/discourse, /var/www/discourse/plugins/discourse-adplugin, /var/www/discourse/plugins/discourse-data-explorer

broke the site:

Rebuilding the app brought the site back up.


#5

That is the exact error I received. Thanks for posting / and re-creating. :star_struck:


(Neil Lalonde) #6

Hmm I don’t understand the problem then. We deploy this to our hosting, and it has no auto_generated directory and doesn’t show an error. We don’t use admin to upgrade though, so it might have something to do with that.