Latest upgrade through Docker screw settings


(Dror Deleon) #1

Hi guys,

I have noticed that since the latest upgrade via /admin/docker the setting entity of “email in min trust” is blank and lack its entities.

What should i do?


(Neil Lalonde) #2

So, you don’t see any values like this?

Do you see any errors in the javascript console?


(Dror Deleon) #3

Exactly @neil, i do not see those values.

Can you please guide me how to open the javascript console?


(Dror Deleon) #4

I have also noticed that the entity of default digest email frequency also lacks its values.

I have tried to rebuild and bootstrap that app and the issue remains.


(Jeff Atwood) #5

I can’t repro this, I just upgraded a Digital Ocean instance and trust level drop down is still present and populated.

Did your upgrade fail in some way? Try upgrading again via the command line on your server:

cd /var/docker/
git pull
./launcher rebuild app


(Antonio Andrade) #6

Hi,

I seem to be having the same issue (on selecting locale, for instance) on a vanilla docker setup.
Already tried rebuilding with no success. There are no errors on the javascript console.


(Jeff Atwood) #7

Did you try the advice in the post directly above yours? Let me know.


(Antonio Andrade) #8

I did.

The issue is consistent across browsers too.

Is there anything I should check to debug this?


(Jeff Atwood) #9

Any unusual non-default settings? Language? anything like that? Is it a stock Docker install?


(Antonio Andrade) #10

Hey Jeff. All defaults - pure stock docker install as per Discourse Meta

The only difference is that I was using a different VPS provider.
For that, I just created a new droplet on DO and followed the same guide. The issue remains.

Also, a week ago I had done another test install and everything worked. Changes were introduced in Discourse since then I believe.


(Dror Deleon) #11

Hi @codinghorror Thanks for your advice.

I tried to update manually - it stated that its allready up-to-date and the rebuilding process didn’t change anything.
Im not sure if the problematic update failed, there is a chance it did. in that can case what can i do? i don’t have any back yet as i just installed it last week,


(Sam Saffron) #12

can you try:

./launcher ssh app
redis-cli flushall

then

./launcher rebuild app


(Dror Deleon) #13

Hi @sam

I have tried what you suggested, the problem remains, any other ideas?


(Antonio Andrade) #14

Hi, also tried this but it made no change.


(Neil Lalonde) #15

I just setup a new site and got this problem too. I’ll investigate.


(Neil Lalonde) #16

@lightyear Do you think it’s the select2 stuff that broke it? All the enum site settings have no values anymore.


(Benjamin Kampmann) #17

Nope. Still working at 13f4afe00f8ecae1adf107335f3f48d6b6b55bc3 (the one exactly one after mine those changes). So I assume you guys broke it after – as I can see it is broken on HEAD at the moment. I can do the git bisect if you want. But then again, it is already way past the work-day for me here, so … I leave this to you guys :wink: .


(Neil Lalonde) #18

I fixed. You used a merge where you should have used merge!

https://github.com/discourse/discourse/commit/a1887c97c6bbdd7c56d41704123045da8bc45cc9#diff-ed2fbbcb9305eeb6e1536cf4413a641cR130


(Jeff Atwood) #19

Sorry about that, everyone. Open source, amirite?


(Jeff Atwood) #20