Latest upgrade window is blank


(Sckott) #1

I maintain a Discourse installation http://discuss.ropensci.org/. I am on v1.2.0.beta6 of Discourse, and there is an available upgrade (v1.2.0.beta8) - The page at /admin/upgrade is blank. Looking at chrome devtools, looks like there’s a 500 error in requesting that page. Is this a problem with my installation?


(Carighan Maconar) #2

That window worked ok for me, but the upgrade process for docker had no actual text displaying in the log window. Although it did eventually complete.


(Rogelio J. Samour) #3

I just created a post that describes the same issue @sckott is experiencing. My post has mysteriously disappeared but we can continue the conversation here I suppose.

@sckott: this seems to be an issue with the docker plugin. Can you take a peek in /logs immediately after you try to visit /admin/upgrade and see if there’s a 500 error in there?


(Rogelio J. Samour) #4

@sckott: here’s my post on the same issue with logs: Upgrade button is 500-ing for me


(Sckott) #5

yeah, just did, and its essentially the same error


(Sckott) #6

UPDATE Looks like it’s fixed


(Lars Doucet) #7

Working for me too, I had exact same issue. What do you suppose it was?


(Sckott) #8

Don’t know, that’s weird that it magically fixed


(Rogelio J. Samour) #9

Not for me. I think my issue is related to the docker plugin itself. Do any of you know how I can upgrade a plugin by hand?


(Dave Shaw) #10

I followed the instructions here to perform the upgrade after getting a blank upgrade page, worked fine.


(Sam Saffron) #11
cd /var/discourse
git pull
./launcher rebuild app

(Jeff Atwood) #12