./launcher doesn't work anymore


(Busta Paladin) #1

I tried the rebuild command after I edited the app.yml but it didnt respond, so I fear I gotta re-install the entire thing now?

I can’t run any of these commands:
Commands:
start: Start/initialize a container
stop: Stop a running container
restart: Restart a container
destroy: Stop and remove a container
enter: Use nsenter to get a shell into a container
logs: View the Docker logs for a container
bootstrap: Bootstrap a container for the config based on a template
rebuild: Rebuild a container (destroy old, bootstrap, start new)
cleanup: Remove all containers that have stopped for > 24 hours


(Joffrey Jaffeux) #2

does it print anything? do you have a backup of the previous file you could use?


(Kane York) #3

What is the exact error message?


(Busta Paladin) #4

It was only a test install for self learning so no I don’t have a droplet or backup. And it doesn’t print anything of an error.

I want to just run it from an IP only is that possible? I’ve pointed a domain to the digital ocean for the SMTP stuff, that all is setup correctly… However I was wondering if its possible to run a discourse on an IP only? No domain at DISCOURSE_HOSTNAME but instead an ip like this http://164.127.183.13 for example


(Jay Pfaffman) #5

That’s odd. I can’t think of a way that could be true. My best guess is that you’re not talking to the shell. Maybe log out and back in again, or reboot?

Not really. And you can’t do mail without a domain name. If you’re doing self-learning, then the first thing to learn about will be how to register and configure a domain name. If you know that already, then just use testing.yourdomain.com for the hostname.


(Busta Paladin) #6

Alright but I got an issue during install:

ENTER to continue, ‘n’ to try again, Ctrl+C to exit:
sed: -e expression #1, char 56: unknown option to `s’
DISCOURSE_HOSTNAME change failed.
Unfortunately, there was an error changing containers/app.yml


(Jay Pfaffman) #7

Hmm. Perhaps you introduced something into app.yml editing it by hand that confused discourse-setup.

Try this:

rm containers/app.yml
./discourse-setup

(Busta Paladin) #8

I got it fully working now, I do wonder though why as admin you cannot change the password or mail on a user by user basis? Like say on Wordpress, phpBB, MyBB, Xenforo; etc.

Say the user proves ownership through IP but no longer has access to his mail account…


(Jay Pfaffman) #9

Because you should never know anyone’s password.

Then change the email address.


(Busta Paladin) #10

Because you should never know anyone’s password.

Well I don’t mean to know them only to reset , change the password to something else.

Password:
Do not change
Set new password:

like that, Xenforo and many other platforms offer such feature.


(Jay Pfaffman) #11

Change the email address to their correct email address and send them to /u/password-reset or /u/password-reset/user@wherever.com

They have to convince Discourse that they own the email address anyway.


(Stephen Chung) #12

Not true. I have successfully used a Discourse installation on IP address only, for internal small circle trials.


(Jay Pfaffman) #13

Great! Then please provide help so that they can do the same.


(Stephen Chung) #14

Well, can’t remember much details… :sweat_smile:

Basically it was just to run through the standard setup with a fictitious domain name that doesn’t exist. After installation is complete, do not use the domain name but use the IP address to access the forum.

Everything, AFAIK, worked fine.

Except for uploads (esp. images) where they will show a URL with the domain name instead of the IP address, so those will all be broken links.

@BustaPaladin you can try the standard setup process with the IP address instead of the domain name – I’m not sure if the setup program will filter the IP address off as an improper domain name, which should not because ddd.ddd.ddd.ddd is technically a valid domain name…

If it does choke on the IP address, then try some fake domain name just to get through the process. Then of course you’ll have broken links on all your image URL’s.