Launcher outputs error about not finding docker.io

docker

#1

When I run the launcher script, it always shows the following message before running the specified command:

I looked the launcher’s code and found the line causing this:

It seems while the line of code will set docker_path to the path of docker.io or docker, one of the which commands will fail causing an error to be printed to the console.

I’m not quite sure how this can be fixed as the which command doesn’t seem to have an option to suppress errors.

The launcher script still functions despite showing this error but it certainly confused me when I first attempted my Discourse install as I thought my Docker install might be broken.

Post Note: I left this uncategorized because the bug category says it’s for bugs that prevent Discourse from working normally and this bug doesn’t stop Discourse from working normally, it’s just makes setup a bit confusing/annoying.


(omfg) #2

I googled the first quoted message and there are several posts on that topic, i.e.

You didn’t mention which OS/version you’re using so it’s probably unlikely someone might be able to give you concrete advice.


(Sebastian Sassi) #3

Same problem here. The bootstrapping worked OK, but the error message confused me too.
I was using the Amazon ECS-Optimized Amazon Linux AMI.