# ./launcher rebuild app error bootstrap failed with exit code 125

**URL:** https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538
**Category:** Self-hosting
**Created:** [March 15, 2024, 3:24pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538 "2024-03-15T15:24:01Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![mrhassan60](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mrhassan60/32/350082_2.png) [@mrhassan60](https://meta.discourse.org/u/mrhassan60)
#### Post date: [March 15, 2024, 3:24pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/1 "2024-03-15T15:24:02Z")

</div>

Hello,

I am facing an issue: I am unable to rebuild Discourse using the command “./launcher rebuild app”, and when I run the command “docker ps”, no Discourse container is visible. However, I can still access Discourse via the web without any problem. How is this possible?

Here are the errors that I encounter when I run the command “./launcher rebuild app”: :

```plaintext
docker: Error response from daemon: error while creating mount source path '/var/discourse/shared/standalone': mkdir /var/discourse: read-only file system.
bootstrap failed with exit code 125
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
f15514ef40f8a25134126ee1c0c7771c60081ce8a8f2f6384be73cbbca7a3d12

```

Result the command docker ps :

```plaintext
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES

```

I want to rebuild Discourse to use it with HTTPS this time, and with Let’s Encrypt.  
Thanks for help

---

<div class="post-metadata">

### Author: ![ecki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ecki/32/264025_2.png) [@ecki](https://meta.discourse.org/u/ecki)
#### Post date: [March 15, 2024, 5:27pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/2 "2024-03-15T17:27:01Z")

</div>

You need to look for errors way back in the logs or console, maybe you had made a incomplete change for the https? Start and revert it to get it going again.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 15, 2024, 6:30pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/3 "2024-03-15T18:30:24Z")

</div>

> [@mrhassan60](#):
>
> `read-only file system`

This is one problem.

> [@mrhassan60](#):
>
> when I run the command “docker ps”, no Discourse container is visible. However, I can still access Discourse via the web without any problem. How is this possible?

Maybe you’re not root?

Maybe you’re on the wrong server?

---

<div class="post-metadata">

### Author: ![ecki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ecki/32/264025_2.png) [@ecki](https://meta.discourse.org/u/ecki)
#### Post date: [March 15, 2024, 11:23pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/4 "2024-03-15T23:23:47Z")

</div>

In the normal mode of launcher.sh docker containers are stopped before they are rebuild, so if the build fails they might miss (not sure if laufender tries to start the old ones as a recovery step?). (I think there is a reduced-downtime mode - which only stops them after the rebuild, not sure why this is not the default since it would help against such corruptions)

That would not explain why you still see discourse however discourse runs offline for quite some time very sneakily 🙂

---

<div class="post-metadata">

### Author: ![mrhassan60](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mrhassan60/32/350082_2.png) [@mrhassan60](https://meta.discourse.org/u/mrhassan60)
#### Post date: [March 18, 2024, 9:41am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/5 "2024-03-18T09:41:57Z")

</div>

Hello,  
Sorry for late answer  
I follow instruction with [Set up HTTPS support with Let's Encrypt](https://meta.discourse.org/t/set-up-https-support-with-lets-encrypt/40709) for https.  
Before i follow instruction with vidéo ([https://www.youtube.com/watch?v=EaUIsIYivE8](https://www.youtube.com/watch?v=EaUIsIYivE8)) for install discourse http (not https) and I had posted a comment on how to install Discourse on Ubuntu using HTTP in forum in december 23. ([Issue with installation in an Ubuntu 22.04 VM - #11 by mrhassan60](https://meta.discourse.org/t/issue-with-installation-in-an-ubuntu-22-04-vm/289335/11))  
I use command with root user `docker ps` and i use server where discourse application is.  
i use command `./discourse-doctor` and i have other error also with error 125 :

```plaintext
Discourse version at forum.dauphine.media: NOT FOUND
Discourse version at localhost: NOT FOUND

```

```plaintext
Unable to find image 'local_discourse/app:latest' locally
docker: Error response from daemon: pull access denied for local_discourse/app, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.

```

```plaintext
Discourse version at forum.dauphine.media: NOT FOUND
Discourse version at localhost: NOT FOUND

```

and discourse turn since 2 months.

sorry for my bad english.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 18, 2024, 9:50am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/6 "2024-03-18T09:50:26Z")

</div>

> [@mrhassan60](#):
>
> `local_discourse/app, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.`

I’ve seen one other report like this. Are you somewhere that access to docker might be blocked?

---

<div class="post-metadata">

### Author: ![mrhassan60](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mrhassan60/32/350082_2.png) [@mrhassan60](https://meta.discourse.org/u/mrhassan60)
#### Post date: [March 18, 2024, 10:21am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/7 "2024-03-18T10:21:07Z")

</div>

i use command `docker run hello-world` if docker works and the command works.

```plaintext
Hello from Docker!
This message shows that your installation appears to be working correctly.

```

---

<div class="post-metadata">

### Author: ![ecki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/ecki/32/264025_2.png) [@ecki](https://meta.discourse.org/u/ecki)
#### Post date: [March 18, 2024, 4:38pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/8 "2024-03-18T16:38:45Z")

</div>

try use “docker pull” instead.

---

<div class="post-metadata">

### Author: ![mrhassan60](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mrhassan60/32/350082_2.png) [@mrhassan60](https://meta.discourse.org/u/mrhassan60)
#### Post date: [March 19, 2024, 9:17am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/9 "2024-03-19T09:17:46Z")

</div>

I used this command `docker pull local_discourse/app:latest` but i have same message :  
`Error response from daemon: pull access denied for local_discourse/app, repository does not exist or may require 'docker login': denied: requested access to the resource is denied`

---

<div class="post-metadata">

### Author: ![mrhassan60](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mrhassan60/32/350082_2.png) [@mrhassan60](https://meta.discourse.org/u/mrhassan60)
#### Post date: [March 20, 2024, 11:48am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/10 "2024-03-20T11:48:11Z")

</div>

I resolve the probleme with new install server discourse.  
Before in old server i save data with administration setting and after i restore data in new server.

In new server Discourse container is visible now

```plaintext
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
e42d24042375 local_discourse/app "/sbin/boot" 25 minutes ago Up 25 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp app

```

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 19, 2024, 11:48am UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-125/299538/11 "2024-04-19T11:48:26Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
