# ./launcher rebuild app error: bootstrap failed with exit code 234

**URL:** https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-234/353999
**Category:** Support
**Created:** [February 23, 2025, 8:22pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-234/353999 "2025-02-23T20:22:55Z")
**Posts on this page:** 1
**Showing post:** 11

<div class="post-metadata">

### Author: ![sjjh](https://avatars.discourse-cdn.com/v4/letter/s/d2c977/32.png) [@sjjh](https://meta.discourse.org/u/sjjh)
#### Post date: [February 28, 2025, 2:31pm UTC](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-234/353999/11 "2025-02-28T14:31:32Z")

</div>

Thanks for all the support, unfortunately it does not solve the problem.

> [@jahan\_gagan](#):
>
> 1. Ensure PNPM is installed: `pnpm --version`

For new users maybe worth to add a:

1. enter container (e.g., `./launcher enter app`

So I did. And `pnp` was already installed:

```plaintext
root@vtdiscourse-app:/var/www/discourse# pnpm --version
9.5.0

```

> [@jahan\_gagan](#):
>
> - Clean up old dependencies:  
> `rm -rf /var/www/discourse/node_modules`  
> `rm -rf /var/www/discourse/app/assets/javascripts/*/node_modules`
> - Pull the lastest code:  
> `cd /var/discourse`  
> `git pull`
> - Rebuild Discourse: `./launcher rebuild app`

I already did, as written in my post above, without solving the problem.

> [@Ed\_S](#):
>
> How old is your installation? Have you previously upgraded successfully? How old is your OS?

Discourse was installed in _April 2023_.  
I did upgrade successfully up (and including) to _v3.4.0.beta3_.  
As written above, the OS is a LXC container, using _Debian bullseye with latest updates installed_.

> [@Ed\_S](#):
>
> Sometimes a problem is due to extensions which are no longer compatible,

The only installed extension is the [Private Topics Plugin](https://meta.discourse.org/t/private-topics-plugin/268646) (still under maintenance and also kept up to date with each discourse update on my side).

> [@Ed\_S](#):
>
> the advice is to share a carefully censored version of your app.yml.

Here we go:

```plaintext
## this is the all-in-one, standalone Discourse Docker container template
##
## After making changes to this file, you MUST rebuild
## /var/discourse/launcher rebuild app
##
## BE *VERY* CAREFUL WHEN EDITING!
## YAML FILES ARE SUPER SUPER SENSITIVE TO MISTAKES IN WHITESPACE OR ALIGNMENT!
## visit http://www.yamllint.com/ to validate this file as needed

templates:
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  ## Uncomment the next line to enable the IPv6 listener
  #- "templates/web.ipv6.template.yml"
  - "templates/web.ratelimited.template.yml"
  ## Uncomment these two lines if you wish to add Lets Encrypt (https)
  ##- "templates/web.ssl.template.yml"
  - "templates/web.ssl.template.yml"
  #- "templates/web.letsencrypt.ssl.template.yml"

## which TCP/IP ports should this container expose?
## If you want Discourse to share a port with another webserver like Apache or nginx,
## see https://meta.discourse.org/t/17247 for details
expose:
  - "80:80" # http
  - "443:443" # https

params:
  db_default_text_search_config: "pg_catalog.english"

  ## Set db_shared_buffers to a max of 25% of the total memory.
  ## will be set automatically by bootstrap based on detected RAM, or you can override
  #db_shared_buffers: "128MB"
  db_shared_buffers: "256MB"

  ## can improve sorting performance, but adds memory usage per-connection
  #db_work_mem: "40MB"

  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed

env:
  LC_ALL: en_US.UTF-8
  LANG: en_US.UTF-8
  LANGUAGE: en_US.UTF-8
  # DISCOURSE_DEFAULT_LOCALE: en

  ## How many concurrent web requests are supported? Depends on memory and CPU cores.
  ## will be set automatically by bootstrap based on detected CPUs, or you can override
  UNICORN_WORKERS: 2

  ## TODO: The domain name this Discourse instance will respond to
  ## Required. Discourse will not work with a bare IP number.
  #DISCOURSE_HOSTNAME: 'discourse.example.com'
  DISCOURSE_HOSTNAME: 'my-discourse-domain.example.com'

  ## Uncomment if you want the container to be started with the same
  ## hostname (-h option) as specified above (default "$hostname-$config")
  #DOCKER_USE_HOSTNAME: true

  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  #DISCOURSE_DEVELOPER_EMAILS: 'me@example.com,you@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'my-admin-mail@example.com'

  ## TODO: The SMTP mail server used to validate new accounts and send notifications
  # SMTP ADDRESS, username, and password are required
  # WARNING the char '#' in SMTP password can cause problems!
  #DISCOURSE_SMTP_ADDRESS: smtp.example.com
  DISCOURSE_SMTP_ADDRESS: my-smtp-server.example.com
  #DISCOURSE_SMTP_PORT: 587
  #DISCOURSE_SMTP_USER_NAME: user@example.com
  DISCOURSE_SMTP_USER_NAME: my-user@my-smtp-server.example.com
  #DISCOURSE_SMTP_PASSWORD: pa$$word
  DISCOURSE_SMTP_PASSWORD: foo(obviously not)
  #DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)
  #DISCOURSE_SMTP_DOMAIN: discourse.example.com # (required by some providers)
  ##DISCOURSE_NOTIFICATION_EMAIL: noreply@discourse.example.com # (address to send notifications from)
  DISCOURSE_NOTIFICATION_EMAIL: my-user@my-smtp-server.example.com # (address to send notifications from)

  ## If you added the Lets Encrypt template, uncomment below to get a free SSL certificate
  #LETSENCRYPT_ACCOUNT_EMAIL: me@example.com

  ## The http or https CDN address for this Discourse instance (configured to pull)
  ## see https://meta.discourse.org/t/14857 for details
  #DISCOURSE_CDN_URL: https://discourse-cdn.example.com
  
  ## The maxmind geolocation IP address key for IP address lookup
  ## see https://meta.discourse.org/t/-/137387/23 for details
  ##DISCOURSE_MAXMIND_LICENSE_KEY: 1234567890123456
  DISCOURSE_MAXMIND_LICENSE_KEY: my-key

## The Docker container is stateless; all data is stored in /shared
volumes:
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared
  - volume:
      host: /var/discourse/shared/standalone/log/var-log
      guest: /var/log

## Plugins go here
## see https://meta.discourse.org/t/19157 for details
hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/communiteq/discourse-private-topics.git

## Any custom commands to run after building
run:
  - exec: echo "Beginning of custom commands"
  ## If you want to set the 'From' email address for your first registration, uncomment and change:
  ## After getting the first signup email, re-comment the line. It only needs to run once.
  #- exec: rails r "SiteSetting.notification_email='info@unconfigured.discourse.org'"
  - exec: echo "End of custom commands"

```

Any help appreciated.

---

_[View the full topic](https://meta.discourse.org/t/launcher-rebuild-app-error-bootstrap-failed-with-exit-code-234/353999)._
