# 런처 앱 재구축 실패

**URL:** https://meta.discourse.org/t/launcher-rebuild-app-failure/294336
**Category:** Self-hosting
**Created:** [2월 6, 2024, 12:53오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336 "2024-02-06T12:53:51Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![omppatil](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/omppatil/32/359876_2.png) [@omppatil](https://meta.discourse.org/u/omppatil)
#### Post date: [2월 6, 2024, 12:53오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/1 "2024-02-06T12:53:52Z")

</div>

안녕하세요!  
`./launcher rebuild app`을 사용하여 Discourse를 재빌드해 보았지만, 재빌드 과정에서 실패하며 다음과 같은 오류가 발생합니다:

```plaintext
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 3316 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap failed with exit code 1
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

```

실제로 저는 로컬 환경에서 개발하여 정상적으로 작동하는 플러그인을 Discourse에 업로드하려고 시도하고 있습니다. 하지만 Discourse 서버에 플러그인을 업로드하면 위의 오류와 함께 다음과 같은 경고들이 표시됩니다:

```plaintext
warning "@discourse/lint-configs > eslint-plugin-ember > ember-eslint-parser@0.2.5" has unmet peer dependency "@typescript-eslint/parser@^6.15.0".
warning "@discourse/lint-configs > eslint-plugin-ember > ember-eslint-parser@0.2.5" has incorrect peer dependency "typescript@^5.3.3".
warning " > @glint/environment-ember-loose@1.3.0" has unmet peer dependency "@glimmer/component@^1.1.2".
warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0"
warning Pattern ["wrap-ansi@^7.0.0"] is trying to unpack in the same destination "/home/discourse/.cache/yarn/v6/npm-wrap-ansi-cjs-7.0.0-67e145cff510a6a6984bdf1152911d69d2eb9e43-integrity/node_modules/wrap-ansi-cjs" as pattern ["wrap-ansi-cjs@npm:wrap-ansi@^7.0.0"]. This could result in non-deterministic behavior, skipping.
warning " > discourse-markdown-it@1.0.0" has unmet peer dependency "xss@*".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse > @uppy/aws-s3@3.0.6" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse > @uppy/aws-s3-multipart@3.1.3" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse > @uppy/xhr-upload@3.1.1" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse > ember-router-service-refresh-polyfill@1.1.0" has incorrect peer dependency "ember-source@^3.4 || 4".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse-plugins > ember-this-fallback@0.4.0" has unmet peer dependency "ember-source@^3.28.11 || ^4.0.0".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > admin > ember-source > router_js@8.0.3" has unmet peer dependency "rsvp@^4.8.5".
warning "workspace-aggregator-98dafb8f-3047-47b1-9d38-9da6ff65f457 > discourse > @uppy/aws-s3 > @uppy/xhr-upload@3.3.0" has incorrect peer dependency "@uppy/core@^3.2.1".

```

`./launcher cleanup`을 사용하여 컨테이너를 정리하고 재빌드를 시도해 보았지만, 아무것도 해결되지 않았습니다.  
이 문제를 해결하는 방법에 대해 도움을 주실 수 있나요?

---

<div class="post-metadata">

### Author: ![Arkshine](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/arkshine/32/298682_2.png) [@Arkshine](https://meta.discourse.org/u/Arkshine)
#### Post date: [2월 6, 2024, 1:08오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/2 "2024-02-06T13:08:06Z")

</div>

> [@omppatil](#):
>
> ```plaintext
> 위쪽으로 스크롤하여 이전 오류 메시지를 찾아보세요. 오류가 하나 이상 있을 수 있습니다.
> 
> ```

안녕하세요,

위와 같이 하거나 로그를 여기에 붙여넣어 주시면 도움이 됩니다. 👍

경고 메시지는 예상된 것이며 무시하셔도 됩니다!

---

<div class="post-metadata">

### Author: ![omppatil](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/omppatil/32/359876_2.png) [@omppatil](https://meta.discourse.org/u/omppatil)
#### Post date: [2월 6, 2024, 1:18오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/3 "2024-02-06T13:18:13Z")

</div>

```plaintext
I, [2024-02-06T12:34:29.772046 #1] INFO -- : > su postgres -c 'createdb discourse' || true
2024-02-06 12:34:29.917 UTC [54] postgres@postgres ERROR: database "discourse" already exists
2024-02-06 12:34:29.917 UTC [54] postgres@postgres STATEMENT: CREATE DATABASE discourse;
createdb: error: database creation failed: ERROR: database "discourse" already exists
I, [2024-02-06T12:34:29.921646 #1] INFO -- : 
I, [2024-02-06T12:34:29.922307 #1] INFO -- : > su postgres -c 'psql discourse -c "create user discourse;"' || true
2024-02-06 12:34:30.035 UTC [58] postgres@discourse ERROR: role "discourse" already exists
2024-02-06 12:34:30.035 UTC [58] postgres@discourse STATEMENT: create user discourse;
ERROR: role "discourse" already exists
I, [2024-02-06T12:34:30.038648 #1] INFO -- : 
I, [2024-02-06T12:34:30.039394 #1] INFO -- : > su postgres -c 'psql discourse -c "grant all privileges on database discourse to discourse;"' || true
I, [2024-02-06T12:34:30.115792 #1] INFO -- : GRANT

I, [2024-02-06T12:34:30.116712 #1] INFO -- : > su postgres -c 'psql discourse -c "alter schema public owner to discourse;"'
I, [2024-02-06T12:34:30.196923 #1] INFO -- : ALTER SCHEMA

I, [2024-02-06T12:34:30.197758 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists hstore;"'
NOTICE: extension "hstore" already exists, skipping
I, [2024-02-06T12:34:30.305929 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.306810 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists pg_trgm;"'
NOTICE: extension "pg_trgm" already exists, skipping
I, [2024-02-06T12:34:30.383971 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.384850 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists vector;"'
NOTICE: extension "vector" already exists, skipping
I, [2024-02-06T12:34:30.456459 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.457296 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists hstore;"'
NOTICE: extension "hstore" already exists, skipping
I, [2024-02-06T12:34:30.535128 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.535940 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists pg_trgm;"'
NOTICE: extension "pg_trgm" already exists, skipping
I, [2024-02-06T12:34:30.606543 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.607292 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists vector;"'
NOTICE: extension "vector" already exists, skipping
I, [2024-02-06T12:34:30.679393 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T12:34:30.680298 #1] INFO -- : > sudo -u postgres psql discourse
I, [2024-02-06T12:34:30.687340 #1] INFO -- : update pg_database set encoding = pg_char_to_encoding('UTF8') where datname = 'discourse' AND encoding = pg_char_to_encoding('SQL_ASCII');

I, [2024-02-06T12:34:30.807686 #1] INFO -- : File > /var/lib/postgresql/take-database-backup chmod: +x chown: postgres:postgres
I, [2024-02-06T12:34:30.818932 #1] INFO -- : File > /var/spool/cron/crontabs/postgres chmod: chown: 
I, [2024-02-06T12:34:30.819617 #1] INFO -- : > echo postgres installed!
I, [2024-02-06T12:34:30.823257 #1] INFO -- : postgres installed!

```

아래로 스크롤하면서 발견한 오류 메시지입니다.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2월 6, 2024, 2:25오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/4 "2024-02-06T14:25:37Z")

</div>

아직도 오류가 없네요. 전체 로그를 공유해 주세요.

당신의 플러그인이 데이터베이스 마이그레이션을 수행하나요? 가능하면 링크를 공유해 주세요.

---

<div class="post-metadata">

### Author: ![omppatil](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/omppatil/32/359876_2.png) [@omppatil](https://meta.discourse.org/u/omppatil)
#### Post date: [2월 6, 2024, 2:34오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/5 "2024-02-06T14:34:45Z")

</div>

다음은 `./launcher rebuild app` 실행 후 전체 로그입니다.

```plaintext
x86_64 아키텍처 감지됨.
런처가 최신 상태인지 확인하는 중
원본(Fetching origin)
런처는 최신 상태입니다
기존 컨테이너 중지 중
+ /usr/bin/docker stop -t 600 app
app
2.0.20231218-0429: discourse/base에서 가져오는 중
Digest: sha256:468f70b9bb4c6d0c6c2bbb3efc1a5e12d145eae57bdb6946b7fe5558beb52dc1
상태: discourse/base:2.0.20231218-0429 이미지가 최신 상태입니다
docker.io/discourse/base:2.0.20231218-0429
/usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups.rb
/usr/local/bin/pups --stdin
I, [2024-02-06T14:18:26.260895 #1] INFO -- : stdin에서 읽는 중
I, [2024-02-06T14:18:26.273805 #1] INFO -- : > locale-gen $LANG && update-locale
I, [2024-02-06T14:18:26.352125 #1] INFO -- : 로케일 생성 중 (시간이 좀 걸릴 수 있습니다)...
생성 완료.

I, [2024-02-06T14:18:26.352980 #1] INFO -- : > mkdir -p /shared/postgres_run
I, [2024-02-06T14:18:26.356630 #1] INFO -- : 
I, [2024-02-06T14:18:26.357542 #1] INFO -- : > chown postgres:postgres /shared/postgres_run
I, [2024-02-06T14:18:26.361423 #1] INFO -- : 
I, [2024-02-06T14:18:26.362096 #1] INFO -- : > chmod 775 /shared/postgres_run
I, [2024-02-06T14:18:26.364494 #1] INFO -- : 
I, [2024-02-06T14:18:26.365242 #1] INFO -- : > rm -fr /var/run/postgresql
I, [2024-02-06T14:18:26.368363 #1] INFO -- : 
I, [2024-02-06T14:18:26.368969 #1] INFO -- : > ln -s /shared/postgres_run /var/run/postgresql
I, [2024-02-06T14:18:26.371436 #1] INFO -- : 
I, [2024-02-06T14:18:26.372124 #1] INFO -- : > socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1
2024/02/06 14:18:26 socat[18] E connect(6, AF=1 "/shared/postgres_run/.s.PGSQL.5432", 36): No such file or directory
I, [2024-02-06T14:18:26.384491 #1] INFO -- : 
I, [2024-02-06T14:18:26.385119 #1] INFO -- : > rm -fr /shared/postgres_run/.s*
I, [2024-02-06T14:18:26.389313 #1] INFO -- : 
I, [2024-02-06T14:18:26.389932 #1] INFO -- : > rm -fr /shared/postgres_run/*.pid
I, [2024-02-06T14:18:26.393828 #1] INFO -- : 
I, [2024-02-06T14:18:26.394439 #1] INFO -- : > mkdir -p /shared/postgres_run/13-main.pg_stat_tmp
I, [2024-02-06T14:18:26.397864 #1] INFO -- : 
I, [2024-02-06T14:18:26.398558 #1] INFO -- : > chown postgres:postgres /shared/postgres_run/13-main.pg_stat_tmp
I, [2024-02-06T14:18:26.401379 #1] INFO -- : 
I, [2024-02-06T14:18:26.407865 #1] INFO -- : File > /etc/service/postgres/run chmod: +x chown: 
I, [2024-02-06T14:18:26.414052 #1] INFO -- : File > /etc/service/postgres/log/run chmod: +x chown: 
I, [2024-02-06T14:18:26.420350 #1] INFO -- : File > /etc/runit/3.d/99-postgres chmod: +x chown: 
I, [2024-02-06T14:18:26.425985 #1] INFO -- : File > /root/upgrade_postgres chmod: +x chown: 
I, [2024-02-06T14:18:26.426819 #1] INFO -- : > chown -R root /var/lib/postgresql/13/main
I, [2024-02-06T14:18:29.957091 #1] INFO -- : 
I, [2024-02-06T14:18:29.958357 #1] INFO -- : > [! -e /shared/postgres_data] && install -d -m 0755 -o postgres -g postgres /shared/postgres_data && sudo -E -u postgres /usr/lib/postgresql/13/bin/initdb -D /shared/postgres_data || exit 0
I, [2024-02-06T14:18:29.962053 #1] INFO -- : 
I, [2024-02-06T14:18:29.962675 #1] INFO -- : > chown -R postgres:postgres /shared/postgres_data
I, [2024-02-06T14:18:30.005248 #1] INFO -- : 
I, [2024-02-06T14:18:30.006245 #1] INFO -- : > chown -R postgres:postgres /var/run/postgresql
I, [2024-02-06T14:18:30.010124 #1] INFO -- : 
I, [2024-02-06T14:18:30.011061 #1] INFO -- : > /root/upgrade_postgres
I, [2024-02-06T14:18:30.025786 #1] INFO -- : 
I, [2024-02-06T14:18:30.026082 #1] INFO -- : > rm /root/upgrade_postgres
I, [2024-02-06T14:18:30.031110 #1] INFO -- : 
I, [2024-02-06T14:18:30.034124 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 data_directory = '/var/lib/postgresql/13/main'을 data_directory = '/shared/postgres_data'로 대체
I, [2024-02-06T14:18:30.035045 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?listen_addresses *=.*)을 listen_addresses = '*'로 대체
I, [2024-02-06T14:18:30.035465 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?synchronous_commit *=.*)을 synchronous_commit = $db_synchronous_commit로 대체
I, [2024-02-06T14:18:30.036472 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?shared_buffers *=.*)을 shared_buffers = $db_shared_buffers로 대체
I, [2024-02-06T14:18:30.037322 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?work_mem *=.*)을 work_mem = $db_work_mem으로 대체
I, [2024-02-06T14:18:30.038051 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?default_text_search_config *=.*)을 default_text_search_config = '$db_default_text_search_config'로 대체
I, [2024-02-06T14:18:30.038858 #1] INFO -- : > install -d -m 0755 -o postgres -g postgres /shared/postgres_backup
I, [2024-02-06T14:18:30.044011 #1] INFO -- : 
I, [2024-02-06T14:18:30.045054 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?checkpoint_segments *=.*)을 checkpoint_segments = $db_checkpoint_segments로 대체
I, [2024-02-06T14:18:30.046123 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?logging_collector *=.*)을 logging_collector = $db_logging_collector로 대체
I, [2024-02-06T14:18:30.046991 #1] INFO -- : /etc/postgresql/13/main/postgresql.conf에서 (?-mix:#?log_min_duration_statement *=.*)을 log_min_duration_statement = $db_log_min_duration_statement로 대체
I, [2024-02-06T14:18:30.048633 #1] INFO -- : /etc/postgresql/13/main/pg_hba.conf에서 (?-mix:^#local +replication +postgres +peer$)을 local replication postgres peer로 대체
I, [2024-02-06T14:18:30.049563 #1] INFO -- : /etc/postgresql/13/main/pg_hba.conf에서 (?-mix:^host.*all.*all.*127.*$)을 host all all 0.0.0.0/0 md5로 대체
I, [2024-02-06T14:18:30.050826 #1] INFO -- : /etc/postgresql/13/main/pg_hba.conf에서 (?-mix:^host.*all.*all.*::1\/128.*$)을 host all all ::/0 md5로 대체
I, [2024-02-06T14:18:30.051424 #1] INFO -- : > HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main
I, [2024-02-06T14:18:30.054166 #1] INFO -- : > sleep 5
2024-02-06 14:18:30.161 UTC [41] LOG: starting PostgreSQL 13.13 (Debian 13.13-1.pgdg110+1) on x86_64-pc-linux-gnu, compiled by gcc (Debian 10.2.1-6) 10.2.1 20210110, 64-bit
2024-02-06 14:18:30.163 UTC [41] LOG: listening on IPv4 address "0.0.0.0", port 5432
2024-02-06 14:18:30.164 UTC [41] LOG: listening on IPv6 address "::", port 5432
2024-02-06 14:18:30.175 UTC [41] LOG: listening on Unix socket "/var/run/postgresql/.s.PGSQL.5432"
2024-02-06 14:18:30.190 UTC [44] LOG: database system was shut down at 2024-02-06 14:15:37 UTC
2024-02-06 14:18:30.203 UTC [41] LOG: database system is ready to accept connections
I, [2024-02-06T14:18:35.059469 #1] INFO -- : 
I, [2024-02-06T14:18:35.059863 #1] INFO -- : > su postgres -c 'createdb discourse' || true
2024-02-06 14:18:35.203 UTC [54] postgres@postgres ERROR: database "discourse" already exists
2024-02-06 14:18:35.203 UTC [54] postgres@postgres STATEMENT: CREATE DATABASE discourse;
createdb: error: database creation failed: ERROR: database "discourse" already exists
I, [2024-02-06T14:18:35.206739 #1] INFO -- : 
I, [2024-02-06T14:18:35.207533 #1] INFO -- : > su postgres -c 'psql discourse -c "create user discourse;"' || true
2024-02-06 14:18:35.330 UTC [58] postgres@discourse ERROR: role "discourse" already exists
2024-02-06 14:18:35.330 UTC [58] postgres@discourse STATEMENT: create user discourse;
ERROR: role "discourse" already exists
I, [2024-02-06T14:18:35.334356 #1] INFO -- : 
I, [2024-02-06T14:18:35.335100 #1] INFO -- : > su postgres -c 'psql discourse -c "grant all privileges on database discourse to discourse;"' || true
I, [2024-02-06T14:18:35.406985 #1] INFO -- : GRANT

I, [2024-02-06T14:18:35.407749 #1] INFO -- : > su postgres -c 'psql discourse -c "alter schema public owner to discourse;"'
I, [2024-02-06T14:18:35.482659 #1] INFO -- : ALTER SCHEMA

I, [2024-02-06T14:18:35.483378 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists hstore;"'
NOTICE: extension "hstore" already exists, skipping
I, [2024-02-06T14:18:35.564958 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.565622 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists pg_trgm;"'
NOTICE: extension "pg_trgm" already exists, skipping
I, [2024-02-06T14:18:35.635827 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.636470 #1] INFO -- : > su postgres -c 'psql template1 -c "create extension if not exists vector;"'
NOTICE: extension "vector" already exists, skipping
I, [2024-02-06T14:18:35.704628 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.705404 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists hstore;"'
NOTICE: extension "hstore" already exists, skipping
I, [2024-02-06T14:18:35.781299 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.781945 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists pg_trgm;"'
NOTICE: extension "pg_trgm" already exists, skipping
I, [2024-02-06T14:18:35.850284 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.850951 #1] INFO -- : > su postgres -c 'psql discourse -c "create extension if not exists vector;"'
NOTICE: extension "vector" already exists, skipping
I, [2024-02-06T14:18:35.919005 #1] INFO -- : CREATE EXTENSION

I, [2024-02-06T14:18:35.919852 #1] INFO -- : > sudo -u postgres psql discourse
I, [2024-02-06T14:18:35.926081 #1] INFO -- : update pg_database set encoding = pg_char_to_encoding('UTF8') where datname = 'discourse' AND encoding = pg_char_to_encoding('SQL_ASCII');

I, [2024-02-06T14:18:36.036112 #1] INFO -- : File > /var/lib/postgresql/take-database-backup chmod: +x chown: postgres:postgres
I, [2024-02-06T14:18:36.044311 #1] INFO -- : File > /var/spool/cron/crontabs/postgres chmod: chown: 
I, [2024-02-06T14:18:36.045089 #1] INFO -- : > echo postgres installed!
I, [2024-02-06T14:18:36.048379 #1] INFO -- : postgres installed!

I, [2024-02-06T14:18:36.054139 #1] INFO -- : File > /etc/service/redis/run chmod: +x chown: 
I, [2024-02-06T14:18:36.060031 #1] INFO -- : File > /etc/service/redis/log/run chmod: +x chown: 
I, [2024-02-06T14:18:36.065442 #1] INFO -- : File > /etc/runit/3.d/10-redis chmod: +x chown: 
I, [2024-02-06T14:18:36.067526 #1] INFO -- : /etc/redis/redis.conf에서 daemonize yes을 으로 대체
I, [2024-02-06T14:18:36.068816 #1] INFO -- : /etc/redis/redis.conf에서 (?-mix:^pidfile.*$)을 으로 대체
I, [2024-02-06T14:18:36.069797 #1] INFO -- : > install -d -m 0755 -o redis -g redis /shared/redis_data
I, [2024-02-06T14:18:36.073493 #1] INFO -- : 
I, [2024-02-06T14:18:36.074402 #1] INFO -- : /etc/redis/redis.conf에서 (?-mix:^logfile.*$)을 logfile ""로 대체
I, [2024-02-06T14:18:36.075399 #1] INFO -- : /etc/redis/redis.conf에서 (?-mix:^bind .*$)을 으로 대체
I, [2024-02-06T14:18:36.076391 #1] INFO -- : /etc/redis/redis.conf에서 (?-mix:^dir .*$)을 dir /shared/redis_data로 대체
I, [2024-02-06T14:18:36.077382 #1] INFO -- : /etc/redis/redis.conf에서 (?-mix:^protected-mode yes)을 protected-mode no로 대체
I, [2024-02-06T14:18:36.078228 #1] INFO -- : /etc/redis/redis.conf에서 # io-threads 4을 io-threads $redis_io_threads로 대체
I, [2024-02-06T14:18:36.079108 #1] INFO -- : > echo redis installed
I, [2024-02-06T14:18:36.082478 #1] INFO -- : redis installed

I, [2024-02-06T14:18:36.083158 #1] INFO -- : > cat /etc/redis/redis.conf | grep logfile
I, [2024-02-06T14:18:36.088540 #1] INFO -- : logfile ""

I, [2024-02-06T14:18:36.089149 #1] INFO -- : > exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
I, [2024-02-06T14:18:36.091164 #1] INFO -- : > sleep 10
110:C 06 Feb 2024 14:18:36.110 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
110:C 06 Feb 2024 14:18:36.111 # Redis version=7.0.7, bits=64, commit=00000000, modified=0, pid=110, just started
110:C 06 Feb 2024 14:18:36.111 # Configuration loaded
110:M 06 Feb 2024 14:18:36.112 * monotonic clock: POSIX clock_gettime
110:M 06 Feb 2024 14:18:36.113 * Running mode=standalone, port=6379.
110:M 06 Feb 2024 14:18:36.114 # Server initialized
110:M 06 Feb 2024 14:18:36.114 * Loading RDB produced by version 7.0.7
110:M 06 Feb 2024 14:18:36.115 * RDB age 179 seconds
110:M 06 Feb 2024 14:18:36.115 * RDB memory usage when created 7.85 Mb
110:M 06 Feb 2024 14:18:36.145 * Done loading RDB, keys loaded: 1117, keys expired: 0.
110:M 06 Feb 2024 14:18:36.146 * DB loaded from disk: 0.031 seconds
110:M 06 Feb 2024 14:18:36.146 * Ready to accept connections
I, [2024-02-06T14:18:46.095442 #1] INFO -- : 
I, [2024-02-06T14:18:46.096340 #1] INFO -- : > thpoff echo "thpoff is installed!"
I, [2024-02-06T14:18:46.116357 #1] INFO -- : thpoff is installed!

I, [2024-02-06T14:18:46.117325 #1] INFO -- : > /usr/local/bin/ruby -e 'if ENV["DISCOURSE_SMTP_ADDRESS"] == "smtp.example.com"; puts "Aborting! Mail is not configured!"; exit 1; end'
I, [2024-02-06T14:18:46.241320 #1] INFO -- : 
I, [2024-02-06T14:18:46.242077 #1] INFO -- : > /usr/local/bin/ruby -e 'if ENV["DISCOURSE_HOSTNAME"] == "discourse.example.com"; puts "Aborting! Domain is not configured!"; exit 1; end'
I, [2024-02-06T14:18:46.367601 #1] INFO -- : 
I, [2024-02-06T14:18:46.368355 #1] INFO -- : > /usr/local/bin/ruby -e 'if (ENV["DISCOURSE_CDN_URL"] || "")[0..1] == "//"; puts "Aborting! CDN must have a protocol specified. Once fixed you should rebake your posts now to correct all posts."; exit 1; end'
I, [2024-02-06T14:18:46.494449 #1] INFO -- : 
I, [2024-02-06T14:18:46.495204 #1] INFO -- : > rm -f /etc/cron.d/anacron
I, [2024-02-06T14:18:46.500083 #1] INFO -- : 
I, [2024-02-06T14:18:46.503817 #1] INFO -- : File > /etc/cron.d/anacron chmod: chown: 
I, [2024-02-06T14:18:46.519146 #1] INFO -- : File > /etc/runit/1.d/copy-env chmod: +x chown: 
I, [2024-02-06T14:18:46.524878 #1] INFO -- : File > /etc/service/unicorn/run chmod: +x chown: 
I, [2024-02-06T14:18:46.530345 #1] INFO -- : File > /etc/service/nginx/run chmod: +x chown: 
I, [2024-02-06T14:18:46.535624 #1] INFO -- : File > /etc/runit/3.d/01-nginx chmod: +x chown: 
I, [2024-02-06T14:18:46.540932 #1] INFO -- : File > /etc/runit/3.d/02-unicorn chmod: +x chown: 
I, [2024-02-06T14:18:46.541436 #1] INFO -- : /etc/service/unicorn/run에서 # postgres을 sv start postgres || exit 1로 대체
I, [2024-02-06T14:18:46.542092 #1] INFO -- : > exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
I, [2024-02-06T14:18:46.545346 #1] INFO -- : > cd /var/www/discourse && sudo -H -E -u discourse git reset --hard
137:C 06 Feb 2024 14:18:46.563 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
137:C 06 Feb 2024 14:18:46.564 # Redis version=7.0.7, bits=64, commit=00000000, modified=0, pid=137, just started
137:C 06 Feb 2024 14:18:46.564 # Configuration loaded
137:M 06 Feb 2024 14:18:46.565 * monotonic clock: POSIX clock_gettime
137:M 06 Feb 2024 14:18:46.566 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
137:M 06 Feb 2024 14:18:46.566 # Failed listening on port 6379 (TCP), aborting.
Updating files: 100% (33715/33715), done.
I, [2024-02-06T14:18:56.293089 #1] INFO -- : HEAD is now at 6ab1a19e9 DEV: Convert min_trust_level_to_allow_invite to groups (#24893)

I, [2024-02-06T14:18:56.301032 #1] INFO -- : > cd /var/www/discourse && sudo -H -E -u discourse git clean -f
I, [2024-02-06T14:18:56.550228 #1] INFO -- : 
I, [2024-02-06T14:18:56.550905 #1] INFO -- : > cd /var/www/discourse && sudo -H -E -u discourse bash -c '
  set -o errexit
  if [$(git rev-parse --is-shallow-repository) == "true"]; then
      git remote set-branches --add origin main
      git remote set-branches origin tests-passed
      git fetch --depth 1 origin tests-passed
  else
      git fetch --tags --prune-tags --prune --force origin
  fi
'
From https://github.com/discourse/discourse
 - [deleted] (none) -> origin/0-drop-code
 - [deleted] (none) -> origin/bulk-button-class
 - [deleted] (none) -> origin/dependabot/bundler/excon-0.108.0
 - [deleted] (none) -> origin/dependabot/bundler/hashdiff-1.1.0
 - [deleted] (none) -> origin/dependabot/bundler/parallel-1.24.0
 - [deleted] (none) -> origin/dependabot/bundler/rubocop-discourse-3.6.0
 - [deleted] (none) -> origin/dependabot/npm_and_yarn/app/assets/javascripts/uppy/drop-target-2.0.2
 - [deleted] (none) -> origin/dev/add-new-chat-metrics
 - [deleted] (none) -> origin/dev/allow-chat-mentions-to-have-several-notifications
 - [deleted] (none) -> origin/dev/convert-min-trust-level-to-create-tag-to-group
 - [deleted] (none) -> origin/dev/convert-min-trust-level-to-ignore-to-groups
 - [deleted] (none) -> origin/dev/rethink-mass-mentions-polymorphic
 - [deleted] (none) -> origin/feature/migrations-schema-generator
 - [deleted] (none) -> origin/fix-join-filter-upload
 - [deleted] (none) -> origin/fix-modal-flash-minor
 - [deleted] (none) -> origin/global-notice-reactive
 - [deleted] (none) -> origin/labeler
 - [deleted] (none) -> origin/low-ram-help
 - [deleted] (none) -> origin/multi-invite
 - [deleted] (none) -> origin/plugin-extra-js
 - [deleted] (none) -> origin/table-builder-modal-modifier
 - [deleted] (none) -> origin/wip_categories
 - [deleted] (none) -> origin/wizard-split
   6ab1a19e9..7fcd7d53f main -> origin/main
 * [new branch] 0-ember-bump -> origin/0-ember-bump
 * [new branch] 0-event-helper -> origin/0-event-helper
 * [new branch] 0-extend-native -> origin/0-extend-native
 * [new branch] 0-rev -> origin/0-rev
 * [new branch] add-api-for-forced-auth -> origin/add-api-for-forced-auth
 * [new branch] amend-visit-copy -> origin/amend-visit-copy
 * [new branch] api-image-wrapper -> origin/api-image-wrapper
 * [new branch] asciinema-iframe -> origin/asciinema-iframe
 * [new branch] bulk-select-dropdown-items -> origin/bulk-select-dropdown-items
 * [new branch] convert-header-to-glimmer -> origin/convert-header-to-glimmer
 * [new branch] decorator-transforms -> origin/decorator-transforms
 * [new branch] dependabot/bundler/omniauth-2.0.0 -> origin/dependabot/bundler/omniauth-2.0.0
 * [new branch] dependabot/bundler/parallel_tests-4.4.0 -> origin/dependabot/bundler/parallel_tests-4.4.0
 * [new branch] dependabot/npm_and_yarn/app/assets/javascripts/content-tag-2.0.1 -> origin/dependabot/npm_and_yarn/app/assets/javascripts/content-tag-2.0.1
 * [new branch] dev-convert-topic-map-expanded-widget-to-component -> origin/dev-convert-topic-map-expanded-widget-to-component
 * [new branch] dev/check-whether-online-user-ids-may-be-memoized-between-job-runs -> origin/dev/check-whether-online-user-ids-may-be-memoized-between-job-runs
 * [new branch] dev/drop-the-user-id-column-from-chat-mentions -> origin/dev/drop-the-user-id-column-from-chat-mentions
 + e0c0191bb...7029ef16f dev/dry-up-user-status-serializers -> origin/dev/dry-up-user-status-serializers (forced update)
 * [new branch] dev/experiment-theme-settings-free-ui -> origin/dev/experiment-theme-settings-free-ui
 * [new branch] dev/make-admins-tl4-in-tests -> origin/dev/make-admins-tl4-in-tests
 * [new branch] dev/promote-plugin-post-deploy-migrations -> origin/dev/promote-plugin-post-deploy-migrations
 * [new branch] dev/proof-of-concept-rewriting-mentions-notification-logic -> origin/dev/proof-of-concept-rewriting-mentions-notification-logic
 * [new branch] dev_category_order_database -> origin/dev_category_order_database
 * [new branch] dev_update_category_position -> origin/dev_update_category_position
 * [new branch] extra-js-revert -> origin/extra-js-revert
 * [new branch] fast-edit-expand-regex -> origin/fast-edit-expand-regex
 * [new branch] feature/add-new-illegal-flag-reason -> origin/feature/add-new-illegal-flag-reason
 * [new branch] feature/custom-date-range -> origin/feature/custom-date-range
 * [new branch] feature/paste-upload-on-first-upload-input-templates -> origin/feature/paste-upload-on-first-upload-input-templates
 * [new branch] feature_async_hashtags -> origin/feature_async_hashtags
 * [new branch] feature_async_load_colors -> origin/feature_async_load_colors
 * [new branch] fix-email-category-badge -> origin/fix-email-category-badge
 * [new branch] fix_category_chooser -> origin/fix_category_chooser
 * [new branch] fix_in_any_groups -> origin/fix_in_any_groups
 * [new branch] fix_reviewable_translation -> origin/fix_reviewable_translation
   7f2bdca65..4f57be1a8 generic-import-latest -> origin/generic-import-latest
 * [new branch] hijacks -> origin/hijacks
 * [new branch] issue/run-admin-sidebar-init-after-logs-notice -> origin/issue/run-admin-sidebar-init-after-logs-notice
 * [new branch] loic-rubocop-plugin-rules -> origin/loic-rubocop-plugin-rules
 + 90a3535b7...e6e64cfd5 migrations-convert -> origin/migrations-convert (forced update)
 * [new branch] promote-migration-tweak -> origin/promote-migration-tweak
 * [new branch] redesign-my-threads-index -> origin/redesign-my-threads-index
 * [new branch] remove-widget-search-menu -> origin/remove-widget-search-menu
 * [new branch] revert-25009-dev/convert-min-trust-to-allow-self-wiki-to-groups -> origin/revert-25009-dev/convert-min-trust-to-allow-self-wiki-to-groups
 * [new branch] revert-bulk-topic-actions -> origin/revert-bulk-topic-actions
 * [new branch] sidebar-above-outlet -> origin/sidebar-above-outlet
 * [new branch] site-logo-height -> origin/site-logo-height
 * [new branch] sort-chat-channels-by-activity -> origin/sort-chat-channels-by-activity
   d7f7f79b6..07fb62331 stable -> origin/stable
 * [new branch] support-reset-bump-date-post-id -> origin/support-reset-bump-date-post-id
 * [new branch] system-test-for-soft-load-search -> origin/system-test-for-soft-load-search
   6ab1a19e9..7fcd7d53f tests-passed -> origin/tests-passed
 * [new branch] unhide_lazy_load_categories -> origin/unhide_lazy_load_categories
 * [new branch] universal-nonce -> origin/universal-nonce
 * [new branch] unread-mobile-indicator -> origin/unread-mobile-indicator
 * [new branch] ux-user-name -> origin/ux-user-name
 * [new branch] virtual-scroll-list -> origin/virtual-scroll-list
 t [tag update] beta -> beta
 t [tag update] latest-release -> latest-release
 * [new tag] v3.1.4 -> v3.1.4
 * [new tag] v3.1.5 -> v3.1.5
 * [new tag] v3.2.0 -> v3.2.0
 * [new tag] v3.2.0.beta4 -> v3.2.0.beta4
 * [new tag] v3.2.0.beta5 -> v3.2.0.beta5
I, [2024-02-06T14:18:58.135755 #1] INFO -- : 
I, [2024-02-06T14:18:58.136372 #1] INFO -- : > cd /var/www/discourse && sudo -H -E -u discourse bash -c '
  set -o errexit
  if [[$(git symbolic-ref --short HEAD) == tests-passed]] ; then
      git pull
  else
      git -c advice.detachedHead=false checkout tests-passed
  fi
'
Switched to a new branch 'tests-passed'
I, [2024-02-06T14:19:06.214070 #1] INFO -- : Branch 'tests-passed' set up to track remote branch 'tests-passed' from 'origin'.

I, [2024-02-06T14:19:06.214701 #1] INFO -- : > cd /var/www/discourse && sudo -H -E -u discourse git config user.discourse-version tests-passed
I, [2024-02-06T14:19:06.230463 #1] INFO -- : 
I, [2024-02-06T14:19:06.231175 #1] INFO -- : > cd /var/www/discourse && mkdir -p tmp
I, [2024-02-06T14:19:06.236452 #1] INFO -- : 
I, [2024-02-06T14:19:06.237281 #1] INFO -- : > cd /var/www/discourse && chown discourse:www-data tmp
I, [2024-02-06T14:19:06.241609 #1] INFO -- : 
I, [2024-02-06T14:19:06.242215 #1] INFO -- : > cd /var/www/discourse && mkdir -p tmp/pids
I, [2024-02-06T14:19:06.246902 #1] INFO -- : 
I, [2024-02-06T14:19:06.247515 #1] INFO -- : > cd /var/www/discourse && mkdir -p tmp/sockets
I, [2024-02-06T14:19:06.251905 #1] INFO -- : 
I, [2024-02-06T14:19:06.252450 #1] INFO -- : > cd /var/www/discourse && touch tmp/.gitkeep
I, [2024-02-06T14:19:06.261339 #1] INFO -- : 
I, [2024-02-06T14:19:06.261955 #1] INFO -- : > cd /var/www/discourse && mkdir -p /shared/log/rails
I, [2024-02-06T14:19:06.267363 #1] INFO -- : 
I, [2024-02-06T14:19:06.268001 #1] INFO -- : > cd /var/www/discourse && bash -c "touch -a /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log"
I, [2024-02-06T14:19:06.275190 #1] INFO -- : 
I, [2024-02-06T14:19:06.275791 #1] INFO -- : > cd /var/www/discourse && bash -c "ln -s /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log /var/www/discourse/log"
I, [2024-02-06T14:19:06.282090 #1] INFO -- : 
I, [2024-02-06T14:19:06.282740 #1] INFO -- : > cd /var/www/discourse && bash -c "mkdir -p /shared/{uploads,backups}"
I, [2024-02-06T14:19:06.288945 #1] INFO -- : 
I, [2024-02-06T14:19:06.289502 #1] INFO -- : > cd /var/www/discourse && bash -c "ln -s /shared/{uploads,backups} /var/www/discourse/public"
I, [2024-02-06T14:19:06.295518 #1] INFO -- : 
I, [2024-02-06T14:19:06.296150 #1] INFO -- : > cd /var/www/discourse && bash -c "mkdir -p /shared/tmp/{backups,restores}"
I, [2024-02-06T14:19:06.303580 #1] INFO -- : 
I, [2024-02-06T14:19:06.304174 #1] INFO -- : > cd /var/www/discourse && bash -c "ln -s /shared/tmp/{backups,restores} /var/www/discourse/tmp"
I, [2024-02-06T14:19:06.310252 #1] INFO -- : 
I, [2024-02-06T14:19:06.310761 #1] INFO -- : > cd /var/www/discourse && chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups /shared/tmp
I, [2024-02-06T14:19:06.327368 #1] INFO -- : 
I, [2024-02-06T14:19:06.328041 #1] INFO -- : > cd /var/www/discourse && [! -d public/plugins] || find public/plugins/ -maxdepth 1 -xtype l -delete
I, [2024-02-06T14:19:06.331433 #1] INFO -- : 
I, [2024-02-06T14:19:06.332174 #1] INFO -- : /etc/service/unicorn/run에서 # redis을 sv start redis || exit 1로 대체
I, [2024-02-06T14:19:06.333086 #1] INFO -- : > cd /var/www/discourse/plugins && git clone https://github.com/discourse/docker_manager.git
Cloning into 'docker_manager'...
I, [2024-02-06T14:19:07.513851 #1] INFO -- : 
I, [2024-02-06T14:19:07.514563 #1] INFO -- : > cd /var/www/discourse/plugins && git clone https://github.com/dvijtest/dsc-hide-post-toggle.git
Cloning into 'dsc-hide-post-toggle'...
I, [2024-02-06T14:19:07.834467 #1] INFO -- : 
I, [2024-02-06T14:19:07.835547 #1] INFO -- : > cp /var/www/discourse/config/nginx.sample.conf /etc/nginx/conf.d/discourse.conf
I, [2024-02-06T14:19:07.852807 #1] INFO -- : 
I, [2024-02-06T14:19:07.853882 #1] INFO -- : > rm /etc/nginx/sites-enabled/default
I, [2024-02-06T14:19:07.858082 #1] INFO -- : 
I, [2024-02-06T14:19:07.858823 #1] INFO -- : > mkdir -p /var/nginx/cache
I, [2024-02-06T14:19:07.862527 #1] INFO -- : 
I, [2024-02-06T14:19:07.864247 #1] INFO -- : /etc/nginx/nginx.conf에서 pid /run/nginx.pid;을 daemon off;로 대체
I, [2024-02-06T14:19:07.865068 #1] INFO -- : /etc/nginx/conf.d/discourse.conf에서 (?m-ix:upstream[^\}]+\})을 upstream discourse { server 127.0.0.1:3000; }로 대체
I, [2024-02-06T14:19:07.865857 #1] INFO -- : /etc/nginx/conf.d/discourse.conf에서 (?-mix:server_name.+$)을 server_name _ ;로 대체
I, [2024-02-06T14:19:07.867191 #1] INFO -- : /etc/nginx/conf.d/discourse.conf에서 (?-mix:client_max_body_size.+$)을 client_max_body_size $upload_size ;로 대체
I, [2024-02-06T14:19:07.867858 #1] INFO -- : /etc/nginx/nginx.conf에서 (?-mix:worker_connections.+$)을 worker_connections $nginx_worker_connections ;로 대체
I, [2024-02-06T14:19:07.868625 #1] INFO -- : > echo "done configuring web"
I, [2024-02-06T14:19:07.871661 #1] INFO -- : done configuring web

I, [2024-02-06T14:19:07.872445 #1] INFO -- : > cd /var/www/discourse && gem install bundler --conservative -v $(awk '/BUNDLED WITH/ { getline; gsub(/ /,""); print $0 }' Gemfile.lock)
I, [2024-02-06T14:19:08.918258 #1] INFO -- : Successfully installed bundler-2.5.3
1 gem installed

I, [2024-02-06T14:19:08.918920 #1] INFO -- : > cd /var/www/discourse && find /var/www/discourse ! -user discourse -exec chown discourse {} \+
I, [2024-02-06T14:19:23.288009 #1] INFO -- : 
I, [2024-02-06T14:19:23.289037 #1] INFO -- : > cd /var/www/discourse && if ["tests-passed" != "tests-passed"]; then
  rm -rf app/assets/javascripts/node_modules
fi
I, [2024-02-06T14:19:23.292704 #1] INFO -- : 
I, [2024-02-06T14:19:23.293207 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'yarn install --frozen-lockfile && yarn cache clean'
warning "@discourse/lint-configs > eslint-plugin-ember > ember-eslint-parser@0.2.5" has unmet peer dependency "@typescript-eslint/parser@^6.15.0".
warning "@discourse/lint-configs > eslint-plugin-ember > ember-eslint-parser@0.2.5" has incorrect peer dependency "typescript@^5.3.3".
warning " > @glint/environment-ember-loose@1.3.0" has unmet peer dependency "@glimmer/component@^1.1.2".
warning Resolution field "unset-value@2.0.1" is incompatible with requested version "unset-value@^1.0.0"
warning Pattern ["wrap-ansi@^7.0.0"] is trying to unpack in the same destination "/home/discourse/.cache/yarn/v6/npm-wrap-ansi-cjs-7.0.0-67e145cff510a6a6984bdf1152911d69d2eb9e43-integrity/node_modules/wrap-ansi-cjs" as pattern ["wrap-ansi-cjs@npm:wrap-ansi@^7.0.0"]. This could result in non-deterministic behavior, skipping.
warning " > discourse-markdown-it@1.0.0" has unmet peer dependency "xss@*".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse > @uppy/aws-s3@3.0.6" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse > @uppy/aws-s3-multipart@3.1.3" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse > @uppy/xhr-upload@3.1.1" has incorrect peer dependency "@uppy/core@^3.1.2".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse > ember-router-service-refresh-polyfill@1.1.0" has incorrect peer dependency "ember-source@^3.4 || 4".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse-plugins > ember-this-fallback@0.4.0" has unmet peer dependency "ember-source@^3.28.11 || ^4.0.0".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > admin > ember-source > router_js@8.0.3" has unmet peer dependency "rsvp@^4.8.5".
warning "workspace-aggregator-ace11c4b-1818-41aa-9048-5d3fd25df83c > discourse > @uppy/aws-s3 > @uppy/xhr-upload@3.3.0" has incorrect peer dependency "@uppy/core@^3.2.1".
I, [2024-02-06T14:22:58.829490 #1] INFO -- : yarn install v1.22.19
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
[4/5] Linking dependencies...
[5/5] Building fresh packages...
$ yarn --cwd app/assets/javascripts $(node -e 'const argv = JSON.parse(process.env.npm_config_argv).original; const passthrough = [`--frozen-lockfile`, `-s`].filter(arg => argv.includes(arg)); console.log(passthrough.join(` `));')
yarn install v1.22.19
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
$ ./run-patch-package
patch-package 8.0.0
Applying patches...
@ember/test-helpers@2.9.4 ✔
babel-plugin-debug-macros@0.3.4 ✔
content-tag@2.0.1 ✔
ember-cli@5.0.0 ✔
ember-this-fallback@0.4.0 (1 deprecation-name) ✔
ember-this-fallback@0.4.0 (2 themes) ✔
ember-this-fallback@0.4.0 (3 exclude-strict-mode) ✔
virtual-dom@2.1.1 ✔
Done in 101.66s.
Done in 193.99s.
yarn cache v1.22.19
success Cleared cache.
Done in 20.02s.

I, [2024-02-06T14:22:58.864095 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle config --local deployment true'
I, [2024-02-06T14:22:59.878242 #1] INFO -- : 
I, [2024-02-06T14:22:59.878878 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle config --local without "development test"'
I, [2024-02-06T14:23:00.186660 #1] INFO -- : 현재 'without' 로컬 값이 "test:development" 이지만 이를 대체하고 있습니다.

I, [2024-02-06T14:23:00.187328 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle install --retry 3 --jobs 4'
I, [2024-02-06T14:24:07.672458 #1] INFO -- : https://rubygems.org/에서 gem 메타데이터 가져오는 중.........
concurrent-ruby 1.2.3 가져오는 중
minitest 5.22.0 가져오는 중
bigdecimal 3.1.6 가져오는 중
cbor 0.5.9.8 가져오는 중
cbor 0.5.9.8 네이티브 확장 포함 설치 중
bigdecimal 3.1.6 네이티브 확장 포함 설치 중
minitest 5.22.0 설치 중
concurrent-ruby 1.2.3 설치 중
excon 0.109.0 가져오는 중
fastimage 2.3.0 가져오는 중
excon 0.109.0 설치 중
fastimage 2.3.0 설치 중
google-protobuf 3.25.2 (x86_64-linux) 가져오는 중
highline 3.0.1 가져오는 중
highline 3.0.1 설치 중
google-protobuf 3.25.2 (x86_64-linux) 설치 중
image_size 3.4.0 가져오는 중
image_size 3.4.0 설치 중
regexp_parser 2.9.0 가져오는 중
logster 2.16.0 가져오는 중
regexp_parser 2.9.0 설치 중
logster 2.16.0 설치 중
stackprof 0.2.26 가져오는 중
stackprof 0.2.26 네이티브 확장 포함 설치 중
nokogiri 1.16.2 (x86_64-linux) 가져오는 중
nokogiri 1.16.2 (x86_64-linux) 설치 중
bootsnap 1.18.3 가져오는 중
bootsnap 1.18.3 네이티브 확장 포함 설치 중
rack-protection 3.2.0 가져오는 중
rack-protection 3.2.0 설치 중
net-http 0.4.1 가져오는 중
net-http 0.4.1 설치 중
sass-embedded 1.70.0 (x86_64-linux-gnu) 가져오는 중
sass-embedded 1.70.0 (x86_64-linux-gnu) 설치 중
puma 6.4.2 가져오는 중
puma 6.4.2 네이티브 확장 포함 설치 중
rbtrace 0.5.1 가져오는 중
rbtrace 0.5.1 네이티브 확장 포함 설치 중
net-imap 0.4.10 가져오는 중
net-imap 0.4.10 설치 중
net-smtp 0.4.0.1 가져오는 중
net-smtp 0.4.0.1 설치 중
activesupport 7.0.8 가져오는 중
activesupport 7.0.8 설치 중
tzinfo-data 1.2024.1 가져오는 중
tzinfo-data 1.2024.1 설치 중
faraday-net_http 3.1.0 가져오는 중
faraday-net_http 3.1.0 설치 중
sassc-embedded 1.70.0 가져오는 중
sassc-embedded 1.70.0 설치 중
activemodel 7.0.8 가져오는 중
activemodel 7.0.8 설치 중
faraday 2.9.0 가져오는 중
faraday 2.9.0 설치 중
actionview 7.0.8 가져오는 중
actionview 7.0.8 설치 중
activejob 7.0.8 가져오는 중
activejob 7.0.8 설치 중
activerecord 7.0.8 가져오는 중
activerecord 7.0.8 설치 중
actionpack 7.0.8 가져오는 중
actionpack 7.0.8 설치 중
actionmailer 7.0.8 가져오는 중
actionmailer 7.0.8 설치 중
railties 7.0.8 가져오는 중
railties 7.0.8 설치 중
Bundle 완료! 138개 Gemfile 종속성, 170개 gem 설치됨.
'development' 및 'test' 그룹의 gem은 설치되지 않았습니다.
Bundled gems는 `./vendor/bundle` 에 설치됩니다.

I, [2024-02-06T14:24:07.673684 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'LOAD_PLUGINS=0 bundle exec rake plugin:pull_compatible_all'
I, [2024-02-06T14:24:15.520240 #1] INFO -- : docker_manager는 이미 최신 호환 버전입니다
dsc-hide-post-toggle는 이미 최신 호환 버전입니다

I, [2024-02-06T14:24:15.521342 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
rake 중단됨!
[dsc-hide-post-toggle] `assets/javascripts` 아래에 있는 Javascript 파일은 자동으로 JS 번들에 포함됩니다.
수동 register_asset 호출은 제거해야 합니다. (javascripts/discourse/initializers/dsc-hide-post-toggle.js.es6 추가 시도)
/var/www/discourse/lib/plugin/instance.rb:666:in `register_asset'
/var/www/discourse/plugins/dsc-hide-post-toggle/plugin.rb:7:in `activate!'
/var/www/discourse/lib/plugin/instance.rb:727:in `instance_eval'
/var/www/discourse/lib/plugin/instance.rb:727:in `activate!'
/var/www/discourse/lib/discourse.rb:347:in `block in activate_plugins!'
/var/www/discourse/lib/discourse.rb:344:in `each'
/var/www/discourse/lib/discourse.rb:344:in `activate_plugins!'
/var/www/discourse/config/application.rb:227:in `block in <class:Application>'
/var/www/discourse/lib/plugin.rb:6:in `initialization_guard'
/var/www/discourse/config/application.rb:227:in `<class:Application>'
/var/www/discourse/config/application.rb:75:in `<module:Discourse>'
/var/www/discourse/config/application.rb:74:in `<top (required)>'
<internal:/usr/local/lib/ruby/site_ruby/3.2.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
<internal:/usr/local/lib/ruby/site_ruby/3.2.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
/var/www/discourse/Rakefile:7:in `<top (required)>'
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rake-13.1.0/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:25:in `load'
/usr/local/bin/bundle:25:in `<main>'
(전체 트레이스를 보려면 --trace 옵션과 함께 태스크를 실행하세요)
I, [2024-02-06T14:24:18.095914 #1] INFO -- : 
I, [2024-02-06T14:24:18.097032 #1] INFO -- : 비동기 프로세스 종료
I, [2024-02-06T14:24:18.097491 #1] INFO -- : HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 41 에 INT 전송
I, [2024-02-06T14:24:18.097819 #1] INFO -- : exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 110 에 TERM 전송
2024-02-06 14:24:18.098 UTC [41] LOG: 빠른 종료 요청 수신
110:signal-handler (1707229458) SIGTERM 수신, 종료 예약...
2024-02-06 14:24:18.119 UTC [41] LOG: 활성 트랜잭션 중단
2024-02-06 14:24:18.128 UTC [41] LOG: 백그라운드 워커 "logical replication launcher" (PID 50)가 종료 코드 1로 종료됨
2024-02-06 14:24:18.129 UTC [45] LOG: 종료 중
2024-02-06 14:24:18.184 UTC [41] LOG: 데이터베이스 시스템이 종료되었습니다
110:M 06 Feb 2024 14:24:18.197 # 사용자가 종료를 요청했습니다...
110:M 06 Feb 2024 14:24:18.199 * 종료 전 최종 RDB 스냅샷 저장.
110:M 06 Feb 2024 14:24:18.264 * 디스크에 DB 저장됨
110:M 06 Feb 2024 14:24:18.266 # Redis는 이제 종료 준비가 되었습니다, 안녕...

실패
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' 실패, 반환값 #<Process::Status: pid 3317 exit 1>
실패 위치: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
실행 실패, 매개변수 {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap 실패, 종료 코드 1
**BOOTSTRAP 실패** 위로 스크롤하여 이전 오류 메시지를 확인하세요. 오류가 여러 개일 수 있습니다.
./discourse-doctor 도구가 문제를 진단하는 데 도움이 될 수 있습니다.

```

---

<div class="post-metadata">

### Author: ![Firepup650](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/firepup650/32/465200_2.png) [@Firepup650](https://meta.discourse.org/u/Firepup650)
#### Post date: [2월 6, 2024, 2:38오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/6 "2024-02-06T14:38:38Z")

</div>

다음은 치명적인 실패로 보입니다:

> [@omppatil](#):
>
> ```plaintext
> I, [2024-02-06T14:24:15.521342 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate'
> rake aborted!
> [dsc-hide-post-toggle] `assets/javascripts` 하위의 Javascript 파일은 자동으로 JS 번들에 포함됩니다.
> 수동 register_asset 호출은 제거해야 합니다. (javascripts/discourse/initializers/dsc-hide-post-toggle.js.es6 추가 시도)
> /var/www/discourse/lib/plugin/instance.rb:666:in `register_asset'
> /var/www/discourse/plugins/dsc-hide-post-toggle/plugin.rb:7:in `activate!'
> /var/www/discourse/lib/plugin/instance.rb:727:in `instance_eval'
> /var/www/discourse/lib/plugin/instance.rb:727:in `activate!'
> /var/www/discourse/lib/discourse.rb:347:in `block in activate_plugins!'
> /var/www/discourse/lib/discourse.rb:344:in `each'
> /var/www/discourse/lib/discourse.rb:344:in `activate_plugins!'
> /var/www/discourse/config/application.rb:227:in `block in <class:Application>'
> /var/www/discourse/lib/plugin.rb:6:in `initialization_guard'
> /var/www/discourse/config/application.rb:227:in `<class:Application>'
> /var/www/discourse/config/application.rb:75:in `<module:Discourse>'
> /var/www/discourse/config/application.rb:74:in `<top (required)>'
> <internal:/usr/local/lib/ruby/site_ruby/3.2.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
> <internal:/usr/local/lib/ruby/site_ruby/3.2.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
> /var/www/discourse/Rakefile:7:in `<top (required)>'
> /var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rake-13.1.0/exe/rake:27:in `<top (required)>'
> /usr/local/bin/bundle:25:in `load'
> /usr/local/bin/bundle:25:in `<main>'
> (전체 트레이스를 보려면 --trace 옵션과 함께 태스크를 실행하세요)
> 
> ```

인스턴스에서 `dsc-hide-post-toggle` 플러그인/테마를 제거하고 다시 빌드해 보시겠습니까?

---

<div class="post-metadata">

### Author: ![omppatil](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/omppatil/32/359876_2.png) [@omppatil](https://meta.discourse.org/u/omppatil)
#### Post date: [2월 6, 2024, 3:17오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/7 "2024-02-06T15:17:20Z")

</div>

> [@omppatil](#):
>
> `수동 register_asset 호출은 제거해야 합니다`

수동 register\_asset 호출을 제거하고 재빌드할 수 있었습니다.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [3월 7, 2024, 3:18오후 UTC](https://meta.discourse.org/t/launcher-rebuild-app-failure/294336/8 "2024-03-07T15:18:07Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
