# Launcher rebuild fails if s3 settings aren't correct

**URL:** <https://meta.discourse.org/t/launcher-rebuild-fails-if-s3-settings-arent-correct/63490>\
**Category:** Bug\
**Created:** [28 Maggio 2017, 4:51am UTC](https://meta.discourse.org/t/launcher-rebuild-fails-if-s3-settings-arent-correct/63490 "2017-05-28T04:51:38Z")\
**Posts on this page:** 1\
**Showing post:** 14

<div class="post-metadata">

**Author:** ![watchmanmonitor](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/watchmanmonitor/32/430970_2.png) [@watchmanmonitor](https://meta.discourse.org/u/watchmanmonitor)\
**Post date:** [3 Giugno 2017, 5:18pm UTC](https://meta.discourse.org/t/launcher-rebuild-fails-if-s3-settings-arent-correct/63490/14 "2017-06-03T17:18:15Z")

</div>

ok, I’ve spent enough time troublehshooting this to be certain:

If the s3 backup settings are incorrect, and `enable_s3_backups` is true, then a normal rebuild will fail.

I manage the site for a friend who entered his s3 keys incorrectly from day 1 and I’ve never had a problem rebuilding his container before.

An update to discourse/discourse\_docker which skips trying to talk to s3, or at least gracefully accepts failure, would mean that people aren’t blindsided by an s3 backup failure during a rebuild

---

_[View the full topic](https://meta.discourse.org/t/launcher-rebuild-fails-if-s3-settings-arent-correct/63490)._
