Like wonkiness after changing ownership of my post to someone else


(Tobias Eigen) #1

I think like doesn’t realize that I have changed the ownership of my post to someone else. When I then like the post, I get the “One person likes this. Like it too” option and not the red heart. If I click on the left part, my own picture shows up. If I click on the right part, I briefly get “undo like” and it goes back to “Like it too” immediately.

Probably easy to replicate but I can’t do it on try or meta, obviously.


When changing post owner, notifications still sent from/to original owner
(Sam Saffron) #3

I just tried to replicate and was unable.


(TechnoBear) #4

I happened to be reading while you were trying, and after you changed ownership of your post to tobiaseigen it showed “1 person liked this” - but clicking on that showed both avatars…


(Tobias Eigen) #5

meanwhile back on my forum the post has changed - it now shows the red heart!

so maybe this is just something to keep in mind when changing ownership of a post… refresh the browser (which I don’t remember trying before posting the bug).


(Sam Saffron) #6

Yes I think this is in the “very very minor” issue bucket.

The bottom line is “stuff gets a bit weird when you change ownership”. The message bus is not forcing a full refresh everywhere when this happens.


When changing post owner, notifications still sent from/to original owner
(Tobias Eigen) #7

Yup - I hear you and understand, and agree it’s not a big deal.

Also see that if I switch ownership back to myself my like remains. :slight_smile:


(Sam Saffron) #8

I am closing this as wontfix, its just way too minor.


(Sam Saffron) #9