Link to referencing topic is not removed after removing link


(Florian) #1

When creating a topic (the referencing topic) and linking to another topic (the referenced topic), a link to the referencing topic is added to the gutter in the referenced topic.

When editing the referencing topic to remove the link to the referenced topic, the link to referencing topic still appears in the gutter of the referenced topic, although it’s not longer referenced.

This also happens when the referencing post is deleted, which might be a different bug, but related.


(Jeff Atwood) #2

Absolutely no repro.

I created a new topic that linked to another topic. Refreshed the browser page on the other topic, see that the gutter link is there.

I then edited the first post of my new topic, and deleted the link. I refreshed the browser page, and see that the gutter link is gone.


(Florian) #3

I’ve updated from 2.2.0.beta5 to v2.2.0.beta5 +82 and the editing issue seems to be fixed.

However, I can still reproduce the issue when the referencing post is deleted where the link to the post is still shown in the gutter of the referenced post. Can you repro?


(Régis Hanol) #4

@jomaxro can you repro this on try.discourse.org?


(Joshua Rosenfeld) #6

Like Jeff earlier, I cannot reproduce this on try.

My steps:

  1. A topic to link to (referenced topic): The Room Appreciation Topic - movies - Demo
  2. A topic with a reply linking to the referenced topic (referencing post): Testing read state without scroll - Demo
  3. Refreshed the referenced topic, gutter link appeared.
  4. Deleted the referencing post.
  5. Gutter link still visible on referenced topic as it was open.
  6. Refresh referenced topic.
  7. Gutter link is gone

@fhe, if you could confirm your specific reproduction steps, and recreate the issue on try.discourse.org that’d be helpful.


(Florian) #7

Thanks for trying to confirm the issue.

I’ve also tried to reproduce on try.discourse.org, without success. However, I can still reproduce it on my own instance following the exact same steps.

The only difference is that I’m performing this as admin and that there is no

but the red post box, showing the actual post content but indicating that the post was deleted.


(Jeff Atwood) #8

Are you using any third party plugins or a non-standard install method?


(Florian) #9

I’ve now tried to repro with a standard test user and cannot reproduce the issue. So it happens only when I perform this as an admin user.

I’m using Discourse via docker, so I guess it’s fairly standard. It’s running on a server that is also running Plesk.

The only non-Discourse plugin I’m using is discourse-migratepassword. Other than that: discourse-solved, discourse-data-explorer, discourse-sitemap.