Links are self-referencing


(Michael) #1

I’ve got the wp-discourse plugin installed. I’ve got it activated. All my settings should be sane and working. Nevertheless, whenever I make a post, the Continue this Discussion link is just a link to the Wordpress posting itself. The following is in my Nginx error logs:

PHP Warning:  in_array() expects parameter 2 to be array, boolean given in /var/
www/mysite/wp-content/plugins/wp-discourse/wp-discourse.php on line 272
PHP message: PHP Warning:  file_get_contents(/wordpress.json?best=5&min_trus
t_level=1&min_score=1&min_replies=1&bypass_trust_level_score=50): fa
iled to open stream: No such file or directory in /var/www/mysite/wp-content/pl
ugins/wp-discourse/wp-discourse.php on line 167" while reading upstream, client:
 (An IP I don't recognize), server: (IP of the Wordpress Server) request: "GET / HTTP/1.1", upstream: "fa
stcgi://unix:/var/run/php5-fpm.sock:", host: "wp.mysite.com"

Anyone able to easily tell me what I’ve screwed up?


#2

I have exactly the same issue here.

Trying to resolve this as we speak.

Did you manage to fix the problem?


(Kane York) #3

Looks like file_get_contents from URLs is disabled. Resolve that with your web host.


#4

Thanks but it’s a different issue.

Still on it!


(Steven Greco) #5

have you figured this out. I am also having this issue. It appeared when i moved from Apache to NGINX on my web server. Turning allow_url_fopen = on in my php.ini allowed comments to now come through on existing posts. I guess this got turned off somehow in the migration. But now I am getting this in my error log when i make a new post.

Can't verify CSRF token authenticity
Discourse::InvalidAccess (Discourse::InvalidAccess)

Which has the post reference itself.

I am still on plugin version 0.61. I noticed there have been some changes on git to version .62 but i cannot get that version to work at all.

EDIT: Nevermind. Recreated my api key fixed the issue.