# Локальная установка Discourse на CentOS 7

**URL:** https://meta.discourse.org/t/local-installation-of-discourse-on-centos-7/150548
**Category:** Self-hosting
**Created:** [06.Май.2020 03:59:21 UTC](https://meta.discourse.org/t/local-installation-of-discourse-on-centos-7/150548 "2020-05-06T03:59:21Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![sanek190](https://avatars.discourse-cdn.com/v4/letter/s/ac8455/32.png) [@sanek190](https://meta.discourse.org/u/sanek190)
#### Post date: [06.Май.2020 03:59:21 UTC](https://meta.discourse.org/t/local-installation-of-discourse-on-centos-7/150548/1 "2020-05-06T03:59:21Z")

</div>

Всем привет!

При установке Discourse в офлайн-режиме на одном из шагов возникает ошибка:

```plaintext
[2020-05-05T17:36:59.349388 #1] INFO -- : > cd /var/www/discourse && su discourse -c 'bundle install --retry 3 --jobs 4 --verbose'

Retrying fetcher due to error (2/4): Bundler::HTTPError Could not fetch specs from https://rubygems.org/
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle install --retry 3 --jobs 4 --verbose' failed with return #<Process::Status: pid 340 exit 17>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["cp -rv /local-rubygems.org/ruby/* $home/vendor/bundle/ruby/", "su discourse -c 'bundle config set deployment \"true\"'", "su discourse -c 'bundle config set without \"development test\"'", "su discourse -c 'bundle install --retry 3 --jobs 4 --verbose'"]}
6637602e5976e07b9e36197d0f6d55a38d528df1688e7fc87173d30aec4e28a5
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

```

Однако я выполнил следующую команду:

```plaintext
docker run -it -v ~/local/rubygems.org:/local-rubygems local_discourse/app /bin/bash
cp -r /var/www/discourse/vendor/bundle/ruby /local-rubygems 

```

Разве после этого Ruby не должен запускаться локально? На сервере проблем с интернетом нет. Что нужно отключить и где прописано ограничение доступа к сайту?

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [06.Май.2020 05:02:11 UTC](https://meta.discourse.org/t/local-installation-of-discourse-on-centos-7/150548/2 "2020-05-06T05:02:11Z")

</div>

Это проблема при подключении к rubygems — глобальному репозиторию всех Ruby-пакетов в интернете.

Рекомендуем выполнить пересборку.

Возможно, ваш IP-адрес или диапазон IP-адресов был признан нежелательным и заблокирован rubygems.
