# Plugin Locations 🌍

**URL:** https://meta.discourse.org/t/locations-plugin/69742
**Category:** Plugin
**Tags:** paid-support
**Created:** [10 Settembre 2017, 10:36am UTC](https://meta.discourse.org/t/locations-plugin/69742 "2017-09-10T10:36:41Z")
**Posts on this page:** 1
**Showing post:** 975

<div class="post-metadata">

### Author: ![xiasummer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/xiasummer/32/82790_2.png) [@xiasummer](https://meta.discourse.org/u/xiasummer)
#### Post date: [12 Dicembre 2023, 12:17pm UTC](https://meta.discourse.org/t/locations-plugin/69742/975 "2023-12-12T12:17:19Z")

</div>

Ho riscontrato lo stesso problema.

Ho provato il metodo elencato qui

> [@\[Solved\]Bootstrap fails, Postgres already running](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041):
>
> Hi, I’m attempting to install Discourse, but am failing so far. It appears that bootstrapping doesn’t want to… bootstrap? Anyhow, I read a couple of other threads about it and tried “./launcher rebuild app”, which gave the following output: WARNING: No memory limit support WARNING: No swap limit support Updating discourse docker Already up-to-date. Calculated ENV: -e LANG=en\_US.UTF-8 -e RAILS\_ENV=production -e UNICORN\_WORKERS=3 -e UNICORN\_SIDEKIQS=1 -e RUBY\_GC\_MALLOC\_LIMIT=40000000 -e RUBY\_HE…

Ma non funziona.  
Sistema Ubuntu, il riavvio non funziona,  
`./launcher restart app`, `./launcher start app` non funzionano.

Messaggio di errore durante l’esecuzione di `./launcher rebuild app`

```plaintext
......
111:M 12 Dec 2023 12:11:02.199 * DB salvato su disco
111:M 12 Dec 2023 12:11:02.200 # Redis è ora pronto per uscire, arrivederci...

FALLITO
--------------------
Pups::ExecError: cd /var/www/discourse & su discourse -c 'bundle exec rake db:migrate' fallito con ritorno #<Process::Status: pid 3553 exit 1>
Posizione del fallimento: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec fallito con i parametri {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap fallito con codice di uscita 1
**FALLITO IL BOOTSTRAP** si prega di scorrere verso l'alto e cercare messaggi di errore precedenti, potrebbero essercene più di uno.

```

Grazie a @itsbhanusharma

> [@itsbhanusharma](#):
>
> Il tuo errore non è lo stesso dell’OP. Potresti fornire il log completo della ricostruzione?

Dice che è causato da un errore precedente, li elenco qui

```plaintext
I, [2023-12-13T00:50:13.222274 #1] INFO -- : > cd /var/www/discourse & su discourse -c 'bundl e exec rake db:migrate'
2023-12-13 00:50:18.347 UTC [3597] discourse@discourse ERRORE: sintassi di input non valida per il tipo double precision: ""

2023-12-13 00:50:18.347 UTC [3597] discourse@discourse STATEMENT: INSERT INTO locations_topic (topic_id, latitude, longitude, name, street, district, city, state, postalcode, country, count rycode, international_code, locationtype, boundingbox, updated_at, created_at) (
          SELECT
          tc.topic_id,
          (tc.value::json->'geo_location'->>'lat')::FLOAT,
          (tc.value::json->'geo_location'->>'lon')::FLOAT,
          tc.value::json->'geo_location'->>'name',
          tc.value::json->'geo_location'->>'street',
          tc.value::json->'geo_location'->>'district',
          tc.value::json->'geo_location'->>'city',
          tc.value::json->'geo_location'->>'state',
          tc.value::json->'geo_location'->>'postalcode',
          tc.value::json->'geo_location'->>'country',
          tc.value::json->'geo_location'->>'countrycode',
          tc.value::json->'geo_location'->>'international_code',
          tc.value::json->'geo_location'->>'type',
          ARRAY[
            (tc.value::json->'geo_location'->'boundingbox'->>0)::FLOAT,
            (tc.value::json->'geo_location'->'boundingbox'->>1)::FLOAT,
            (tc.value::json->'geo_location'->'boundingbox'->>2)::FLOAT,
            (tc.value::json->'geo_location'->'boundingbox'->>3)::FLOAT
          ],
          tc.updated_at,
          tc.created_at
        FROM topic_custom_fields tc
        WHERE tc.name = 'location'
        AND tc.value NOT IN ('\"{}\"', '{}', '')
        AND tc.value::json->'geo_location'->>'lat' IS NOT NULL
        AND tc.value::json->'geo_location'->>'lon' IS NOT NULL
        )
        ON CONFLICT DO NOTHING

rake aborted!
StandardError: Si è verificato un errore, questa e tutte le migrazioni successive sono state annullate: (StandardError)

ERRORE: sintassi di input non valida per il tipo double precision: ""
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.3.0/lib/patches/db/pg.rb: 110:in `exec'
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.3.0/lib/patches/db/pg.rb: 110:in `async_exec'
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mini_sql-1.5.0/lib/mini_sql/postgres/connection.rb:202:in `run'

#--------------
Causato da:
PG::InvalidTextRepresentation: ERRORE: sintassi di input non valida per il tipo double precision: "" (PG:: InvalidTextRepresentation)
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.3.0/lib/patches/db/pg.rb: 110:in `exec'
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.3.0/lib/patches/db/pg.rb: 110:in `async_exec'
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/mini_sql-1.5.0/lib/mini_sql/postgres/connection.rb:202:in `run'

```

e il messaggio di `docker ps`

```plaintext
/var/discourse# docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d3c8e85149a8 local_discourse/app \"/sbin/boot\" About an hour ago Up 6 minutes 0.0.0.0:80->80/tcp, :::80->80/tcp, 0.0.0.0:443->443/tcp, :::443->443/tcp app

```

---

_[View the full topic](https://meta.discourse.org/t/locations-plugin/69742)._
