Login broken in latest revision


(Jan Philip Gehrcke) #1

I am running the latest that was offered in the /admin/docker, rebuilt the container, and now obtain a

The page you requested doesn't exist or is private.

when I am trying to log in. I have set Discourse to require login in order to view content. Pretty sure that this is the same as observed by two other users here: Problem with the login required setting

So this looks to need an urgent fix.


"Popular" and "Recent" should not show on error page if login required to view content
(Jeffrey C Witt) #2

I have the same problem here


(Jan Philip Gehrcke) #3

By the way, this is the corresponding production.log output:

Started GET "/login" for 146.xx.xx.xx at 2014-07-26 18:03:30 +0000
Processing by StaticController#show as HTML
  Parameters: {"id"=>"login"}
  Rendered exceptions/not_found.html.erb within layouts/no_js (14.5ms)
  Rendered common/_special_font_face.html.erb (2.2ms)
  Rendered common/_discourse_stylesheet.html.erb (56.9ms)
  Rendered layouts/_head.html.erb (79.0ms)
  Rendered text template (0.0ms)
Completed 404 Not Found in 146ms (Views: 1.0ms | ActiveRecord: 19.6ms)

(Régis Hanol) #4

Thanks for reporting that, I just pushed a fix

https://github.com/discourse/discourse/commit/3d6e2713d167d9d47e1b377e935e04ebe62a800b


(Jakob Borg) #5

Awesome! Could we request some test for login-with-login-required be added to whatever it is that runs before the tests-passed branch is updated? This is the second or so time within a few weeks where sites with login required break. :wink:


(Régis Hanol) #6

I included a test in my fix :wink: What was the other issue?


(Jakob Borg) #7

Excellent! The other issue was for activating new users when login is required:


(Régis Hanol) #8

This topic was automatically closed after 12 hours. New replies are no longer allowed.