Login disappear


(Ueih Gnad) #1

username suddenly disappear, seem i didn’t login but actually i’ admin and i can create new Categories. I tried to login again but unsuccessful

And here is production.log

Processing by SessionController#create as */*
  Parameters: {"login"=>"admin", "password"=>"[FILTERED]"}
Completed 200 OK in 605ms (Views: 0.3ms | ActiveRecord: 21.9ms)
Started POST "/login" for 198.143.33.1 at 2013-10-15 11:33:19 +0000
Processing by StaticController#enter as HTML
  Parameters: {"username"=>"admin", "password"=>"[FILTERED]", "redirect"=>"http://forums.mydiscourse.net/categories"}
Redirected to http://forums.mydiscourse.net/categories
**Completed 302 Found in 110ms** (ActiveRecord: 51.4ms)

Please help me


(Luke Larris) #2

Try clearing your cookies for that site.


(Ueih Gnad) #3

Please tell me how,i’m newbie
I reboot but didn’t work
Thanks


(Nicholas Smith) #4

How to clear browser cookies

http://www.aboutcookies.org/page-2


(Ueih Gnad) #5

i think not my browser. i used some browsers with clean profile,and some users but still got this problem


#6

I noticed the same problem after latest forum upgrade. Its not cookies and should be fixed urgently.


(Amit Friedmann) #7

Same here. I’ve noticed that after login it looks like I am not, but I can do admin stuff (as the admin user). I can’t reply to post or write a private massage tough.
It seems like a timing thing, as usually refreshing the browser after a minute or so show the user as logged in.


(Keith Newton) #8

I also have this problem. I had just assumed it was because I’ve made some changes to logout and I broke something but after waiting a minute and refreshing the browser the login status is correctly displayed. This is after logging out and then immediately back in, it still shows you as logged out unless you modify the URL in some small way.


(Sam Saffron) #9

Can you try again on latest, I just fixed it.


(Ueih Gnad) #10

still get error :frowning:


(Ueih Gnad) #11

@sam i have updated but still error(followed official Discourse Setup)

# Run these commands as the discourse user
bluepill stop
bluepill quit
# Back up your install
DATESTAMP=$(TZ=UTC date +%F-%T)
pg_dump --no-owner --clean discourse_prod | gzip -c > ~/discourse-db-$DATESTAMP.sql.gz
tar cfz ~/discourse-dir-$DATESTAMP.tar.gz -C /var/www discourse
# get the latest Discourse code
cd /var/www/discourse
git checkout master
git pull
git fetch --tags
# To run on the latest numbered release instead of bleeding-edge:
#git checkout latest-release
#
# Follow the section below titled:
# "Check sample configuration files for new settings"
#
bundle install --without test --deployment
RUBY_GC_MALLOC_LIMIT=90000000 RAILS_ENV=production rake db:migrate
RUBY_GC_MALLOC_LIMIT=90000000 RAILS_ENV=production rake assets:precompile
# restart bluepill
crontab -l
# Here, run the command to start bluepill.
# Get it from the crontab output above.

i don’t understand why?


(Ueih Gnad) #12

hmm,this bug affected to official Discourse ,please check and fix urgent :frowning:



Login not work correctly
(Sam Saffron) #13

Please try again:


(Keith Newton) #14

It looks like this change has completely broken login on my forums. I am writing the _t cookie with the auth token and a domain of .mydomain.com from my root domain mydomain.com. The discourse forums are on forums.mydomain.com. When I access discourse I see the _t cookie and all appears well except that it doesn’t show the account as logged in. I instrumented default_current_user_provider::has_auth_cookie? and it is correctly reading the _t cookie with the proper auth token and returning true. Despite this I still can’t login whereas before I could.


(Sam Saffron) #15

you can override the current user provider and implement it as you see fit


(Sam Saffron) #16

This topic was automatically closed after 1 day. New replies are no longer allowed.