Logs page now 404s. Take 2


(PJH) #1

Continuing the discussion from Logs page now 404s:

Since you so carelessly closed the previous thread as WONTFIX because CANTREPRODUCE. Or because of some prejudice because of which forum I came from. Can’t quite decide yet.

Regardless, the following screenshot was taken with the mouse over the “Logs” ‘pill’.

Note the URL at the bottom left. Which, strangely, takes me to:

 404.


(Manthan Mallikarjun) #2

Try going to:

http://what.thedailywtf.com/admin/logs/staff_action_logs


(PJH) #3

@nahtnam - indeed. However that has nothing to do with this bug report.

Or the last one.


(Jeff Atwood) #4

Regardless, what happens when you click the word “Logs”?

I am not aware of any way to navigate to that path you indicated other than typing it in.

If you can provide a click by click repro of the 404 happy to recategorize. Bugs are for things that are actually broken, per the category description.

Seeing an incorrect tool tip is not broken functionality.


(PJH) #5

The one I did in fact click to get the second screenshot?

Already done.


(Jeff Atwood) #6

How do you click the status bar tooltip? Is this some crazy Firefox-ism? Is that what you are saying? Mouse over the status bar tooltip at the bottom of the browser and click that?

Workaround: click the giant word Logs at the top of the page.


(PJH) #7

The one I did in fact click to get the second screenshot? Already done mate. The non-tooltip you seem to think is a tooltip disappears when the mouse stops being over the Logs at the top of the page.

[quote]Mouse over the status bar tooltip at the bottom of the browser and click that?[/quote] No.


(Manthan Mallikarjun) #8

What version of Discourse are you using?

If im not wrong, the bug you are reporting is that when you click “logs” it gives you a 404?


(PJH) #9

Fairly recent - it’s certainly been updated in the past 24 hrs.

Docker reporting:

discourse (33cbb2a)

New Version Available!
Remote Version: (5477325)Last Updated: 2 hours ago 7 new commits


(Manthan Mallikarjun) #10

Have you tried git pull?

Its really weird that you are the only one with this problem.

Try with another browser like Chrome.


(PJH) #11

This is basic <a href... stuff.

I only have DC admin, not ssh or docker access beyond what’s provided via the web interface.


(Manthan Mallikarjun) #12

Why dont you have access to ssh? Who installed Discourse for you?


(Jeff Atwood) #13

Ok, then this has to be a Firefox specific bug, I just don’t get any 404s clicking that in Chrome or IE11 or Mobile Safari. No repro at all. I rarely use Firefox, I will check later after the kids go to bed on my desktop.


(Sam Saffron) #14

This is now fixed:

https://github.com/discourse/discourse/commit/b560b11f6e2380057aac125b230e2a79c5d9a908

The repro is very subtle, right click on the logs tab, open in new tab, breaks in all browsers.

I added the route.


(Sam Saffron) #15

(Sam Saffron) #16

@PJH fyi that route didn’t exist before today I think you just happened to start triggering with middle click or something.